I have simple solution for that just add float number 0.0 to variable int number.
That will also work, as will multiplying by 1.0. I do feel that casting makes the intention more clear, which should improve code readability, but that might be a matter of taste and style.
BTW, I feel that something called "floatout()" can be assumed to take a float and that as casting from int to float -where needed- is automatic in ChucK you should not need to do any of this here. If that doesn't work (again I don't have Max) then I'd call that a minor bug or at least a inconsistency. If I were you I'd look into whether you really need to do any of this and if so report it to chuck~'s maintainer as a suggestion.
Yours,
Kas.