> - (added) dynamic, resizable arrays
> .size( int ) resizes array; .size() returns current size()
> << operator appends new elements into array
Is this really right? are we doing right-to-left assignment now?
I think the idea is that a value is appended, which means (reading left to right) it ends up on the right end of the array so it's easiest to visualise it as "entering from the right". I could also imagine a ">>" operator that would enter values at the beginning of the array, moving the rest one step to the right. I like it for appending single numbers, so far.
This seems in tune with the general "like you read it" philosophy of ChucK;
32 => Std.motof => my_osc.freq;
is more readable to me then the equivalent
my_osc.freq( Std.mtof( 32) );
However, now re run into the situation where if we'd like to append a float we need to do this;
my_pitches_array << Std.mtof( 32);
Instead of sending the number into mtof like;
//warning; non-valid!!!
my_pitches_array << 32 => Std.mtof;