[chuck-dev] BUG! miniAudicle compilation on Xcode, and anything involving Snow Leopard (maybe?)

Andrew C. Smith acsmith at willamette.edu
Sat Oct 17 18:31:08 EDT 2009

1. The Xcode file seems to be missing chuck_shell.cpp. This turned out
to be an issue, for some obscure reason.

2. I had to add the flag -D__ALTER_ENTRY_POINT__ to the build of the
miniAudicle target, because it kept saying that _main was defined
twice. It was, with one time in chuck_main.cpp and another in main.cpp
(the miniAudicle main() routine).

Both of these worked to make the program compile, but when I started
it up and tried turn on the VM the whole program froze. I'm on Snow
Leopard, but this happened when gidora came out. Everything worked
just fine for the previous version, and it even worked when I replaced
the chuck source with my own code and ran hacked versions.

My initial thought is that maybe there is some tag somewhere that
defines things asking if the system is 10.5, and so 10.6 just fails to
register. But then, not even the downloaded binary works for me. I
probably could have brought this up right when gidora came out, but it
just slipped my mind. Any ideas, and other experiences with Snow
Leopard and the mini? For the record, ChucK works just fine. I'm
thinking it has something to do with the two main() declarations,
since it doesn't crash until I start the VM, but who knows.


More information about the chuck-dev mailing list