[chuck-users] miniAudicle- failed to build on Gentoo Linux

schwaahed schwaahed at gmail.com
Fri Aug 25 09:46:32 EDT 2006

> I have also made ebuild for : chuck, audicle, sndpeek, tapestrea
> Cédric

Hey Cedric,

I was successful with your chuck, sndpeek, & tapestrea ebuilds.

The audicle ebuild failed with this error:

i686-pc-linux-gnu-g++ -D__LINUX_JACK__ -D__CHUCK_STAT_TRACK__
`pkg-config --cflags gtk+-2.0` -c -I../lang/chuck-
-march=pentium-m -O2 -pipe -msse3 -fomit-frame-pointer
-D__CK_SNDFILE_NATIVE__ -D_USE_FTGL_FONTS_ audicle_net.cpp
yacc -dv -b chuck ../lang/chuck-
yacc: e - line 83 of "../lang/chuck-", syntax error
%expect 35
make: *** [chuck.tab.c] Error 1

!!! ERROR: media-sound/audicle- failed.
Call stack:
  ebuild.sh, line 1543:   Called dyn_compile
  ebuild.sh, line 938:   Called src_compile
  audicle-, line 68:   Called die

!!! emake failed
!!! If you need support, post the topmost build error, and the call
stack if relevant.

!!! This ebuild is from an overlay: '/usr/portage/local/layman/sunrise'

When compiling the audicle on my own I got the same error and fixed it with Ge's
help. It involved commenting out 1 line in chuck.y I have included
Ge's message to
me [Chuck-dev] below.

Thanks again!

Ge Wang 	
<gewang at cs.princeton.edu> to ChucK
	 More options	  Aug 16

For some reason, you may have to comment out that line in chuck.y under
certain systems.  Give it a try if you want, and let us know if it helps.



More information about the chuck-users mailing list