[chuck-users] Looping in Chuck and installing problems

Spencer Salazar ssalazar at princeton.edu
Fri May 26 20:07:16 EDT 2006

On May 26, 2006, at 7:05 PM, Hans Leeuw wrote:

> Hi list,
> I am working with the miniAudicle and I must say I am very pleased and
> impressed with the editor and the "On the fly" possibilities thus far.


> I could not find a way though to work
> with buffers and looping as in Max/MSP or Super Collider (without  
> writing
> audio to disk first). Is this to be implemented in the future or is  
> there a
> way to do this already?

As has been mentioned, you could try filling a big array with samples  
from whichever ugen your are using, and then feed that into an  
impulse ugen.

> Audicle and miniAudicle are installed and worked fine (except for  
> loading
> soundfiles).

What is the problem you are having loading soundfiles?  If youre  
getting "could not stat file ..." errors, it could be because older  
versions of miniAudicle basically required absolute pathnames to be  
supplied to sndbuf ugens.  The most recent version of miniAudicle  
lets you change the current directory, in the preferences, so that  
pathnames are interpreted relative to that directory.

Im not as familiar with the Audicle but I imagine sndbuf errors might  
result from similar relative filename issues, depending on where/how  
you invoked the Audicle.

> If I want to use the chuck commandline in the terminal (MacOs
> 10.3.9) I get this message when trying to start the virtual machine  
> with
> chuck --loop:
> cannot bind to tcp port 8888...

the ChucK on-the-fly commands operate by communicating through a  
standard TCP port, 8888.  Are you perhaps running another application  
at the same time that uses this port?  That would cause this sort of  

For example, the miniAudicle actually also uses port 8888 to accept  
remote on the fly commands, so if you were running miniAudicle and  
then tried to run chuck --loop, you would get that error.  If that is  
what is happening, you can disable this functionality in the  
miniAudicle preferences and chuck --loop should work.

hope this helps

More information about the chuck-users mailing list