[chuck-users] adsr

eduard aylon eduard.aylon at gmail.com
Mon Sep 11 08:48:14 EDT 2006


Hi,

> Aha.  This happens because keyOff() is called before the ADSR is in  
> the
> sustain state.  I've fixed it so that the releaseTime is as expected
> even if keyOff is called way early: 1010.

thanks

>
> The changes in CVS and will be included in 1.2.0.7.

When building chuck from cvs in macintel got the following:

make -f makefile.osx
bison -dv -b chuck chuck.y
gcc -D__MACOSX_CORE__ -O3 -c chuck.tab.c
flex -ochuck.yy.c chuck.lex
gcc -D__MACOSX_CORE__ -O3 -c chuck.yy.c
gcc -D__MACOSX_CORE__ -O3 -c chuck_main.cpp
gcc -D__MACOSX_CORE__ -O3 -c chuck_errmsg.cpp
gcc -D__MACOSX_CORE__ -O3 -c chuck_utils.cpp
gcc -D__MACOSX_CORE__ -O3 -c chuck_symbol.cpp
gcc -D__MACOSX_CORE__ -O3 -c chuck_table.cpp
gcc -D__MACOSX_CORE__ -O3 -c chuck_temp.cpp
gcc -D__MACOSX_CORE__ -O3 -c chuck_absyn.cpp
gcc -D__MACOSX_CORE__ -O3 -c chuck_type.cpp
gcc -D__MACOSX_CORE__ -O3 -c chuck_emit.cpp
gcc -D__MACOSX_CORE__ -O3 -c chuck_frame.cpp
gcc -D__MACOSX_CORE__ -O3 -c chuck_instr.cpp
/usr/include/sys/types.h:86: error: declaration does not declare  
anything
make[1]: *** [chuck_instr.o] Error 1
make: [osx] Error 2 (ignored)

No probs on ppc.
If I'm not mistaken this was the very same error which happened when  
building tapestrea (first release) on macintels.

any ideas how to fix it?

thanks,

eduard






More information about the chuck-users mailing list