[chuck-users] determining the type of an Object in code
signal.automatique at gmail.com
Wed Feb 11 00:25:29 EST 2009
2009/2/11 mike clemow <gelfmuse at gmail.com>
> If getType() was stubbed out, then my guess is that we shouldn't mess
> with it. Perhaps we should change the name of this method to
> something else. getClass() maybe...
How about ".isA( type)" that would return true or false ?
I'm suggesting that because some object may be
...all at the same time. So; "my_sitar" would return true for all those and
if ( my_sitar.isA( Event ) ) do.someThing();
Does that make sense to you?
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the chuck-users