[chuck-users] 10.6 multiple chucks

Brad Garton garton at columbia.edu
Thu Jan 7 00:25:40 EST 2010

The ports are probably for control info like OSC or audicle or something, I imagine.

Tried the --port7777, no go on OSX.

They both have different pids (and I even tried renaming the executable just for the heck of it in one try).

Something's going on in CoreAudio...


On Jan 6, 2010, at 11:59 PM, Kassen wrote:

> 2010/1/7 Brad Garton <garton at columbia.edu>
> Jeez this is weird.  I don't think it's an "older code" issue -- I can run two independent CMIX processes with no problems, and our code is downright *ancient*.  I don't understand how two independent processes from two independent shells can interfere.
> Well, clearly they aren't independent then. We know for sure that they are trying to claim the same port at localhost and we also know they are both trying to connect to the audio system. I just tried and I get the same on Linux (though for me the dac being taken on Alsa is also a issue). Even with --silent the second instance fails to start claiming about a port issue. Starting the second with "--port7777" works, aside from the main dac being taken. This is with both instances being
> can that behaviour be replicated on OSX?
> Yours,
> Kas.
> _______________________________________________
> chuck-users mailing list
> chuck-users at lists.cs.princeton.edu
> https://lists.cs.princeton.edu/mailman/listinfo/chuck-users

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.cs.princeton.edu/pipermail/chuck-users/attachments/20100107/af837a8b/attachment.html>

More information about the chuck-users mailing list