[chuck-users] Problems with running ChucK in terminal (Windows 7 64-bit): no sound!

chriswicks crwicks at yahoo.com
Wed Apr 25 12:21:01 EDT 2012

Hey, all.  I didn't get any replies the first time around so I'm trying again!

I now have a discrete sound card (Asus Xonar) and I reinstalled Windows 7 Pro 64-bit from scratch.

I installed the chuck.exe in the System32 folder.  It works from the command line as it should now (I get accurate textual output from the program), but I'm not getting any sound at all now.  It has full permissions on the system and I'm running as administrator.  I have no sound problems otherwise, and miniAudicle is working fine (it produces sound).

Does anyone have any suggestions on how to go about fixing this issue?

Here's some of the output from chuck -v --loop that I think may be relevant:

| devices adc: 0 dac: 0 (default 0)

| initializing 'real-time' audio...
| RtApiDs: callback thread error...
| (RtApiDs: Unable to lock buffer during playback (Primary Sound Driver): Invalid parameter...)

Perhaps it has something to do with real-time audio?  Everything worked without a hitch on my W7 Home Premium 64-bit laptop, and I certainly have better audio capabilities on my desktop.  If it would be helpful to provide the full output, I can, I just haven't gotten around to installing a terminal with cut/paste functionality yet!  My main priority before all else is to get a command-line version of ChucK working as it should!

 From: [chriswicks] <crwicks at yahoo.com>
To: ChucK Mailing List <chuck-users at lists.cs.princeton.edu> 
Sent: Monday, April 16, 2012 1:59 PM
Subject: [chuck-users] Problems with running VM in terminal (Windows 7 64-bit)

Hello all!  I am having a strange problem on my desktop PC running Windows 7 Professional 64-bit.  I have the chuck.exe binary installed for both the Windows cmd prompt (Windows/System32 folder) and for Cygwin, and it works directly (i.e. chuck foo.ck).  However, when I start the VM using chuck --loop, I can't seem to add any shreds to the VM.  It doesn't throw an error message or anything, and it appears to start as it should, it just doesn't seem to be listening to any input that I throw at it.  I type "chuck + foo.ck" and there is no error message and no output in the terminal that is running "chuck --loop".  The same error occurs in both Cygwin and in the basic Windows command-line programs.  I have everything working fine (having followed the same exact steps) on my laptop running Windows 7 Home Premium 64-bit, and everything works fine (with some Jack finagling) on my Linux partition on both machines, but I'd like to be able to work in
 Windows on my desktop, as that is where I spend the bulk of my time for now.

Thanks for any advice!

chuck-users mailing list
chuck-users at lists.cs.princeton.edu
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.cs.princeton.edu/pipermail/chuck-users/attachments/20120425/7d3c25a1/attachment.html>

More information about the chuck-users mailing list