[chuck-users] [BUG] otf blocks at error

fernando alonso lualobus at gmail.com
Thu Feb 9 08:50:12 EST 2012


Hi chuckers

I have a question for you!! I am testing with chuck (capture/playback)
using a device that is already used for other process. And when I execute
my chuck program I have the next output:

... RtApiAlsa: pcm capture open (hw:Headset,0) error: Device or resource
busy.


The point is that I have configured my .asoundrc file to fix the device as
shared for several streams an process, using the asym property. But I
follow with the same error.

BestRegards!







2012/2/2 Kassen <signal.automatique at gmail.com>

> Some more data points;
>
> It turns out I was mistaken and that a [enter] doesn't get the command
> to "unblock" and a Ctrl+c is needed. I also got this;
>
>
> $ chuck -v + otf_b.ck
> [chuck]:(2:SYSTEM): setting log level to: 5 (INFORM)...
> [chuck]:(5:INFORM): examining otf command '+'...
> [chuck]:(5:INFORM): otf connect: 127.0.0.1:8888
> [chuck]:(5:INFORM):  | sending file:args 'otf_b.ck' for add...
> [otf_b.ck]:line(23).char(9): syntax error
> [chuck]: skipping file 'otf_b.ck' for [add]...
>
> Which seems to indicate that it gets past the error reporting before
> it gets stuck, which counts against my previous speculation that error
> reporting might be causing issues. Oh, well, that's what speculation
> is for.
>
> Yours,
> Kas.
> _______________________________________________
> chuck-users mailing list
> chuck-users at lists.cs.princeton.edu
> https://lists.cs.princeton.edu/mailman/listinfo/chuck-users
>



-- 
Fernando Alonso Martín
famartin at ing.uc3m.es
Lualobus at gmail.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.cs.princeton.edu/pipermail/chuck-users/attachments/20120209/3733d52e/attachment.htm>


More information about the chuck-users mailing list