[chuck-users] Heavy distortion/clipping in Windows

Moisés Gabriel Cachay Tello xpktro at gmail.com
Mon Feb 16 14:54:43 EST 2015


This might be a long post, so I apologize if it results a bit boring to

First of all, I want to thank every single person behind ChucK: creators,
mantainers and users, the work you guys are doing is invaluable! You all
have my respect and admiration.

I have posted a couple of answers in this list, since I was part of the
Coursera introduction course. Because of (mostry work-related) some things
that took most of the little time I had, I (sadly :() left ChucK behind. A
couple weeks ago, however, I managed to get the ChucK book and 'regenerate'
my interest in the language.

I'm facing an odd problem during my journey. Following the examples
provided in the book (and also writing my own pieces), sometimes the output
sound gets heavily disorted as if the sound levels go far beyond the
maximum and there's an extreme clipping sound. So I put a gain behind and
set it's level lower of if there's an nRev, I set the mix down, everything
resulting in a very quiet sound, in a strong contrast of what I would
expect the sound to be. I'm attaching a sample of the distortion produced
by playing the Listing 8.9 (Jazz Band) from the book [1]. The code running
is unmodified. Set your headphones/speakers low since this can be very

The weirdest part of all this, is that this distortion only occurs when the
code is running 'live'. If I use the 'Export' function in miniAudicle, the
resulting sound is crystal-clear. I've also used a simple snippet to record
the output to a file manually and the same good-sounding result occurs. I
tried using another sound interface (as far as I know, the HDMI counts as
another audio interface), and an external interface embedded into my
Beringher UMA25S MIDI controller with the same results every time.

I'm at x64 W7 with a Realtek HD embedded soundcard (it's a mid 2013
laptop). I'm not using any sound-boosting software (I found one that came
with my laptop, disabled it and the same result shows). I'm using
miniAudicle 1.3.3 (didn't tried the command line version since I guess the
results will be the same) with pretty much the default settings: default
input/output devices, 44.1KHz sample rate and 128 bytes buffer size (higher
latencies doesn't make any difference).

Since I don't know how to properly diagnose/solve this problem, I hope some
of you can give me some insight to get over this and keep ChucKing :)

 PS: It seems my email got lost somewhere in time, due to the attachment so
I'm replacing it to a direct download link:

[1] https://www.dropbox.com/s/spa3r6os1hgrb0i/distortion.mp3?dl=0

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.cs.princeton.edu/pipermail/chuck-users/attachments/20150216/529663f4/attachment.html>

More information about the chuck-users mailing list