[chuck-users] keyboard fail

David Loberg Code d.loberg.code at wmich.edu
Sat Oct 31 12:22:17 EDT 2015

Spencer and Bob,
  The problem is not exclusively an El Capitan issue. It was already happening in Yosemite before she upgraded.
  We have tried other device numbers. If it is a correct device number, it will open the keyboard but not receive data. If it is an incorrect device number, it gives the 'couldn’t open' response.  (As I indicated, we also tried connecting an external USB keyboard.)


Fra: Bob Bob <estecorreoesdebobi at gmail.com>
Emne: Re: [chuck-users] keyboard fail
Dato: 31. oktober 2015 01:10:39 GMT-4
Til: ChucK Users Mailing List <chuck-users at lists.cs.princeton.edu>
Svar til: ChucK Users Mailing List <chuck-users at lists.cs.princeton.edu>

I've hesitated to update to el capitan because a lot of people have been having issues.
I also have the latest MacBook pro but 15" and everything works so far.

2015-10-28 19:06 GMT-06:00 Spencer Salazar <spencer at ccrma.stanford.edu>:
Hi David,

I will test this on my end also but some times an OS version update will introduce "ghost" HID's, especially keyboards or trackpads, that can be opened but do not generate data. This has happened a few times before. The way to check is to change the kbNum and see if using a different number (1, 2, 3, etc.) produce data. You only need to try this until you see "couldn't open keyboard #" for whichever number after 0, which means you've exhausted the list of things ChucK thinks is a keyboard. 

Otherwise this could be a new issue specific to El Capitan :(


On Wed, Oct 28, 2015 at 11:16 AM, David Loberg Code <d.loberg.code at wmich.edu> wrote:
I have a student with a MacBook Pro (Retina, 13", early-2015). She was on Yosemite with latest ChucK build; now on El Capitan with the ChucK beta build ( beta).  The same problem happened in both builds.

She can open the keyboard with Hid. It will successfully pull the kb.name and print it.
However, it won’t detect any other activity from the keyboard.
It gets stopped at kb=>now; and won’t go any further. We have tried an external USB keyboard too, and it produces the same problem.

Anyone else have this happen OR have a cure?



David Loberg Code
Western Michigan University
code at wmich.edu

Hid kb;
HidMsg kbMsg;
0 => int kbNum;
kb.openKeyboard( kbNum ) => int kbAvailable;
if ( kbAvailable == 0 ) me.exit();
<<< "keyboard '", kb.name(), "' ready" >>>;

while (true) {
    // hangs up waiting for kb=>now event
    kb => now;
    while(kb.recv(kbMsg))  {
        if (kbMsg.isButtonDown()) {
            kbMsg.key => int keyNum;
            <<< "#", keyNum >>>;
        } //end button down       
   } // end while hid.recv
} // end while(true)


David Loberg Code
School of Music
Western Michigan University
1903 W Michigan Ave
Kalamazoo, MI 49008-5434
code at wmich.edu

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.cs.princeton.edu/pipermail/chuck-users/attachments/20151031/a489e77f/attachment.html>

More information about the chuck-users mailing list