[chuck-users] sndfilelib for compiling chuck 1.3...

Iain Emsley iain.emsley at kellogg.ox.ac.uk
Thu Sep 24 02:57:19 EDT 2015

Hi Forrest,

I had this error and installed the libasound2-dev package to solve it on an Ubuntu 14.04 machine. This provides the header files for asound which is what you are missing.

All best,


Iain Emsley

Software Engineer
Oxford e-Research Centre
University of Oxford

On 23 Sep 2015, at 21:48, Forrest Curo <treegestalt at gmail.com<mailto:treegestalt at gmail.com>> wrote:

I've just tried the instructions for compiling/installing chuck 1.3; and these worked exactly as given, on a confuser running ubuntu 15.04.

On another, with ubuntu 14.04 -- I find the compilation crashing for lack of "asoundlib.h"

Assuming that this is part of the libsndfile listed as a dependency on your download page, I followed the link to http://www.mega-nerd.com/libsndfile/#Download and installed that.

However, back in the .... chuck/src directory, I'm still getting:
~/chuck-$ make linux-alsa
g++ -I. -Ilo -O3 -D__LINUX_ALSA__ -D__PLATFORM_LINUX__ -O3 -fno-strict-aliasing -D__CK_SNDFILE_NATIVE__  -c RtAudio/RtAudio.cpp -o RtAudio/RtAudio.o
RtAudio/RtAudio.cpp:5267:28: fatal error: alsa/asoundlib.h: No such file or directory
 #include <alsa/asoundlib.h>

chuck-users mailing list
chuck-users at lists.cs.princeton.edu<mailto:chuck-users at lists.cs.princeton.edu>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.cs.princeton.edu/pipermail/chuck-users/attachments/20150924/314c2d95/attachment.html>

More information about the chuck-users mailing list