[chuck-users] chugins will not load/compile using on windows10

Spencer Salazar spencer.salazar at gmail.com
Fri May 25 14:20:42 EDT 2018

Compilation of Chugins on Windows has not been pretty. Right now the system
is designed so to allow a complete build from command line using some
version of the VS compiler and msbuild, but as I recall this entails an
elaborate and brittle setup of environment variables and $PATH
configuration. Any recommendations/pull requests for getting the system to
work a little more nicely would be welcome. Updating the build tools
version sounds like a good start.

When I have a moment I will look into this myself (I don't have a permanent
Windows set up), but Im also optimistic about Jack's workaround above.


On Wed, May 23, 2018 at 7:54 AM, Jack Atherton <lja at ccrma.stanford.edu>

> Hi Ben,
> Sorry to hear you went down that rabbit hole. I believe the intended
> action is to retarget the solution to whatever is on your machine for
> building the Chugins.
> I've just set up my own Windows machine within the last few days, and
> installed miniAudicle this morning. What I am seeing when I start the VM
> with log level = info is that miniAudicle is only looking in C:\Program
> Files\ChucK\chugins\ for the location of chugins, instead of looking in all
> the folders of the miniAudicle chugins preferences pane window. This is an
> old bug that I think we fixed at some point, but maybe the official
> installer didn't get updated yet. The installer actually installs the
> chugins at C:\Program Files (x86)\ChucK\chugins\ if you choose the default
> install location, so the temporary fix is to make a new folder C:\Program
> Files\ChucK\chugins\ and copy all of the chugins over into there.
> If you set the ChucK>Log Level>Info in the menu bar before starting the
> VM, you should be able to see a printout of where it is scanning for
> chugins and which ones it loads successfully in the console window. When I
> did this on my new laptop, I was able to get it to load all the provided
> chugins, and run a script using one of them without syntax errors.
> Again, sorry for the hassle. Let me know if this works.
> Best,
> Jack
> On Tue, May 22, 2018 at 7:26 PM, Ben Sandvik <bpsandvik at gmail.com> wrote:
>> That kind of makes sense because when I have installed there is a
>> chugins folder created that has a bunch of .CHUG files dated 10/21/2015.
>> These all work in  However, I cant install or use any of the newer
>> chugins in on Win10 and when upgrading to none of them work.
>> I have also tried to compile the chugins from the github repo as you
>> suggested, so far no luck and it has sent me down quite the rabbit hole
>> trying to find the right combination of Visual Studio versions, build
>> tools, SDKs, Windows 2010 compilers, etc. etc.  I am now stuck on build
>> errors that I just cant figure out.
>> The main issue with compiling the chugins in chuck on Windows 10
>> seems to be the use of the v100 build tools in the makefile for each
>> chugin. I think I have installed every v100 related build tool on the
>> internet :)
>> running 'make win32' from mingw64 results in the following errors for the
>> ABSaturator (the first chugin in the makefile) and stops compiling:
>> "Build FAILED.
>> "C:\Users\Ben\chugins\ABSaturator\ABSaturator.vcxproj" (default target)
>> (1) ->
>> (PrepareForBuild target) -> C:\Program Files
>> (x86)\MSBuild\Microsoft.Cpp\v4.0\Microsoft.CppBuild.targets(297,5):
>> warning MSB8003: Could not find WindowsSDKDir variable from the registry.
>> TargetFrameworkVersion or PlatformToolset may be set to an invalid version
>> number. [C:\Users\Ben\chugins\ABSaturator\ABSaturator.vcxproj]
>> "C:\Users\Ben\chugins\ABSaturator\ABSaturator.vcxproj" (default target)
>> (1) ->
>> (ClCompile target) -> C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4
>> .0\Platforms\Win32\Microsoft.Cpp.Win32.Targets(153,5): error MSB6006:
>> "CL.exe" exited with code -1073741515. [C:\Users\Ben\chugins\ABSatura
>> tor\ABSaturator.vcxproj]"
>> I noticed on the github that a fix on Jan 17 that changed the toolset of
>> each chugin from v141 to v100, so as an experiment I changed each line of
>> <PlatformToolset>v100</PlatformToolset> back to
>> <PlatformToolset>v141</PlatformToolset> in the ABSaturator makefile.
>> Running make win32 resulted in a pretty verbose log and a statement in
>> mingw64 of a successful build for ABSaturator!!
>> Next, running sudo make install resulted in the following:
>> $ make install
>> CHUCK_STRICT=1 make -C ABSaturator/ install
>> make[1]: Entering directory 'C:/Users/Ben/chugins/ABSaturator'
>> gcc -O3 -Werror -c -o ABSaturator.o ABSaturator.cpp
>> process_begin: CreateProcess(NULL, gcc -O3 -Werror -c -o ABSaturator.o
>> ABSaturator.cpp, ...) failed.
>> make (e=2): The system cannot find the file specified.
>> So I moved the contents of ABSaturator/Release to ABSaturator/ and
>> changed the file name of ABSaturator.obj to ABSaturator.o and ran make
>> install again.  This time, no log of any ABSaturator activity.  I tried
>> using the chugin again in miniAudicle and got the same 'undefined type'
>> error.
>> So ... are there any Windows 10 users or devs that have succesfully
>> installed and used the chugins for  Any guidance would be
>> appreciated. Ihave basically used all my free time for a week on this.  I
>> really want to use the ArrayOutOfBounds line number features and to try out
>> the new NHHall reverb :)
>> Thanks
>> Ben
>> On Wed, May 16, 2018 at 2:19 AM, Jack Atherton <lja at ccrma.stanford.edu>
>> wrote:
>>> I am pretty sure that chugins that worked with 1.3.X have an internal
>>> version number that is incompatible with -- the API for chugins
>>> changed. You could try recompiling the chugins from the chugin repo and
>>> seeing if that works. I am not sure if the Windows installer also installs
>>> chugins like the Mac installer does (at least, I'm pretty sure the Mac
>>> installer does).
>>> That sounds nasty about the log level crash. I wonder if it is something
>>> that happens when attempting to load incompatible chugins... we should
>>> probably fix it if that's what's going on!
>>> -Jack
>>> On Tue, May 15, 2018 at 11:10 PM, Ben Sandvik <bpsandvik at gmail.com>
>>> wrote:
>>>> List,
>>>> I have been trying to update to chuck for a few days, but I
>>>> can't get chugins to compile or load on Windows 10 64-bit using
>>>> miniAudicle.  I'm getting the "undefined type '...'  in declaration" error
>>>> message for every chugin when adding to the VM, including ones that had
>>>> been working correctly with  Other .ck files that don't use
>>>> chugins seem to be working fine.  Here is what I have tried
>>>> Downloaded the 1.4 executable and went through the standard
>>>> installation
>>>> I have copied the files from the chugins GitHub zip file to:
>>>> C:\WINDOWS\system32/ChucK
>>>> C:\ProgramFiles\ChucK\chugins
>>>> C:\ProgramFiles(x86)\ChucK\chugins
>>>> and made sure the directory is listed under the chugins preferences in
>>>> miniAudicle.  Not sure which is best directory, just trying everything.
>>>> I have also tried just putting the github files for a specific chugin
>>>> in the same folder with an example .ck files.  Still the same error message.
>>>> If I uninstall 1.4 and re-install the older chugins are working
>>>> fine, but newer ones like Wavetable and ExpEnv are not.
>>>> Any ideas?  Am I missing some obvious step during installation?  Is
>>>> there a Windows10-specific issue?
>>>> Also, not sure if this is related, but changing the Log Level to
>>>> anything other than System causes miniAudicle to crash when starting the vm.
>>>> thanks
>>>> Ben
>>>> <https://www.avast.com/sig-email?utm_medium=email&utm_source=link&utm_campaign=sig-email&utm_content=webmail&utm_term=icon> Virus-free.
>>>> www.avast.com
>>>> <https://www.avast.com/sig-email?utm_medium=email&utm_source=link&utm_campaign=sig-email&utm_content=webmail&utm_term=link>
>>>> <#m_3282469593605501594_m_-5689126269115495148_m_-7921755889847518136_m_7236496386533434902_DAB4FAD8-2DD7-40BB-A1B8-4E2AA1F9FDF2>
>>>> <#m_3282469593605501594_m_-5689126269115495148_m_-7921755889847518136_m_7236496386533434902_DAB4FAD8-2DD7-40BB-A1B8-4E2AA1F9FDF2>
>>>> _______________________________________________
>>>> chuck-users mailing list
>>>> <#m_3282469593605501594_m_-5689126269115495148_m_-7921755889847518136_m_7236496386533434902_DAB4FAD8-2DD7-40BB-A1B8-4E2AA1F9FDF2>
>>>> chuck-users at lists.cs.princeton.edu
>>>> https://lists.cs.princeton.edu/mailman/listinfo/chuck-users
>>> _______________________________________________
>>> chuck-users mailing list
>>> chuck-users at lists.cs.princeton.edu
>>> https://lists.cs.princeton.edu/mailman/listinfo/chuck-users
>> _______________________________________________
>> chuck-users mailing list
>> chuck-users at lists.cs.princeton.edu
>> https://lists.cs.princeton.edu/mailman/listinfo/chuck-users
> _______________________________________________
> chuck-users mailing list
> chuck-users at lists.cs.princeton.edu
> https://lists.cs.princeton.edu/mailman/listinfo/chuck-users

Spencer Salazar, PhD
Special Faculty
Music Technology: Interaction, Intelligence, and Design
California Institute of the Arts

ssalazar at calarts.edu | +1 831.277.4654
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.cs.princeton.edu/pipermail/chuck-users/attachments/20180525/61c88331/attachment.html>

More information about the chuck-users mailing list