[parsec-users] vips and fluidanimate on Solaris/SPARC

jcupitt at gmail.com jcupitt at gmail.com
Tue Jul 1 04:31:50 EDT 2008


Hi, I'm one of the vips maintainers.

2008/7/1 Major <mbb45 at cornell.edu>:
> I noticed in the usergroups people had issues with vips unable to find
> certain libraries when compiled on Solar/SPARC. I modified the path so the
> parsec libc is read first before the system glibc, but that didnt solve the
> issue. The previous person in the newsgroup that had this issue didn't
> respond whether that fix had worked for them.

I expect that's a typo, but in case it isn't, you need to get vips to
see the parsec glib before the system glib. This has nothing to do
with libc or glibc. glib is a library of utility functions and types
for C, rather like the STL for C++.

vips needs version 2.6 or later, but the one shipped with solaris is
still 2.4. To get vips to see the parsec one, you need to set
PKG_CONFIG_PATH and possibly LD_LIBRARY_PATH. I don't know how the
parsec build system works, but it should be easy to check these two
variables are being set correctly.

This is the previous post I remember on this subject, is this the one
you found also?

https://lists.cs.princeton.edu/pipermail/parsec-users/2008-March/000009.html

John


More information about the parsec-users mailing list