[parsec-users] vips and fluidanimate on Solaris/SPARC

jcupitt at gmail.com jcupitt at gmail.com
Wed Jul 2 06:53:03 EDT 2008


2008/7/2 Major <mbb45 at cornell.edu>:
> I forgot to export the variable after setting it, doing that gave me the
> proper ouput via the pkg-config command.

Great!

> However, after doing that, and getting the output you've described below, I
> still get the same error with the parsec output:

The undefeined symbols are the things that were added in glib 2.6, so
it sounds like you are still seeing the system glib ahead of the
parsec glib.

If these errors are happening at link-time, you need to see where the
parsec build system is injecting the output of pkg-config --libs, and
check that the values are correct. If it's at run-time, look for a
missing --rpath, or missing lib areas from LD_LIBRARY_PATH.

> When I tried compiling vips standalone, it has issues during the make
> process:

It sounds like (perhaps) your ImageMagick install is old or messed up.
Try configuring vips standalone with

  ./configure --without-magick ... etc.

and see if that fixes it.

John


More information about the parsec-users mailing list