[parsec-users] compiling parsec for simics

Christian Bienia cbienia at CS.Princeton.EDU
Thu Mar 20 15:11:54 EDT 2008


Hi Manu,

It looks like the linker can't find two libraries (libc and libstdc++) in the 
versions which are required. You should check whether your system has these 
libraries available as static libraries. It is also possible that your 
library path gets messed up and the linker is not looking at the location 
where those libraries are. It seems you are using a non-standard installation 
of gcc, but the linker tries to link the system libraries. This might be 
wrong in the case of libstdc++.

You should try to get some more information. The GNU linker will tell you what 
files it is considering if you use the --trace argument. You can inspect the 
contents of libraries with the tool nm.

If everything else fails you should try to build the latest version of gcc 
yourself if you haven't done that yet. I've seen gcc installations that were 
messed up on various Linux distributions. Simply building your own gcc from 
scratch might fix your problems.

- Chris


On Wednesday 19 March 2008 11:47 pm, Manu Awasthi wrote:
> Hi all,
> I have been trying to compile parsec (statically linked) programs for
> simics environment (Linux/UltrSparc). I tried to compile just
> bodytrack using the following options for the configure script -
>
> ./configure --prefix=$HOME --enable-static --disable-shared
> --enable-static-link=libstdc++ --enable-static-link=libc
> --enable-static-link=libstdc++ --enable-static-link=libgcc
> CC="gcc-4.2" CFLAGS="-static -static-libgcc" CCFLAG="-static
> -static-libgcc" CXX="g++-4.2" CXXFLAGS="-static -static-libgcc"
> LDFLAGS="-static -static-libgcc"
>
> Somehow the binary is not getting statically linked. When I run this
> on the above mentioned simics environment, here's the error I get -
>
> ./bodytrack: /usr/lib/libstdc++.so.6: version `CXXABI_1.3.1' not found
> (required by ./bodytrack)
> ./bodytrack: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by
> ./bo dytrack)
>
> Any ideas as to what I am doing wrong?
>
> Thanks,
> Manu
> _______________________________________________
> parsec-users mailing list
> parsec-users at lists.cs.princeton.edu
> https://lists.cs.princeton.edu/mailman/listinfo/parsec-users



More information about the parsec-users mailing list