[parsec-users] bodytrack with openMP

Christian Bienia cbienia at CS.Princeton.EDU
Tue May 6 14:59:35 EDT 2008


Hi Huan,

The last time I tried the OpenMP version of bodytrack it worked fine. It
seems your compiler doesn't support certain flags. Try compiling bodytrack
without parsecmgmt and the most recent version of gcc and see what happens.

You can select which parallelization to use at the command line when you run
bodytrack. To run it with OpenMP via parsecmgmt you have to modify the
.runconf files in the parsec/ directory so it selects OpenMP by default.
Look at the main function of bodytrack to see how to do that.

-Chris



-----Original Message-----
From: parsec-users-bounces at lists.cs.princeton.edu
[mailto:parsec-users-bounces at lists.cs.princeton.edu] On Behalf Of Huan Fang
Sent: Tuesday, May 06, 2008 9:48 AM
To: PARSEC Users
Subject: [parsec-users] bodytrack with openMP

Hi Chris,

Have you tried to compile bodytrack with openMP enabled? I modified this 
line
  # Global arguments to configure script
  build_conf_global="--prefix=${pkginstdir} --enable-openmp

in parsecmgmt, but the compilation stops with error:

 /usr/bin/g++ -DHAVE_CONFIG_H -I. 
-I/localdisk/cmp08/parsec-1.0/bin/../pkgs/apps/bodytrack/src/FlexImageLib 
-I.. -O3 -funroll-loops -fprefetch-loop-arrays -fpermissive 
-fno-exceptions -DPARSEC_VERSION=1.0 -DENABLE_PARSEC_HOOKS 
-I/localdisk/cmp08/parsec-1.0/bin/../pkgs/libs/hooks/inst/i686-linux.gcc-hoo
ks/include 
-fexceptions -Wno-unknown-pragmas -openmp -Wall -MT FlexImage.lo -MD -MP 
-MF .deps/FlexImage.Tpo -c 
/localdisk/cmp08/parsec-1.0/bin/../pkgs/apps/bodytrack/src/FlexImageLib/Flex
Image.cpp  
-fPIC -DPIC -o .libs/FlexImage.o
cc1plus: .libs/FlexImage.d: No such file or directory
cc1plus: warning: -fprefetch-loop-arrays not supported for this target 
(try -march switches)
make[2]: *** [FlexImage.lo] Error 1
make[2]: Leaving directory 
`/localdisk/cmp08/parsec-1.0/pkgs/apps/bodytrack/obj/i686-linux.gcc-hooks/Fl
exImageLib'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory 
`/localdisk/cmp08/parsec-1.0/pkgs/apps/bodytrack/obj/i686-linux.gcc-hooks'
make: *** [all] Error 2
[PARSEC] Error: 'env CXXFLAGS=-O3 -funroll-loops -fprefetch-loop-arrays 
-fpermissive -fno-exceptions -DPARSEC_VERSION=1.0 -DENABLE_PARSEC_HOOKS 
-I/localdisk/cmp08/parsec-1.0/bin/../pkgs/libs/hooks/inst/i686-linux.gcc-hoo
ks/include 
-fexceptions make' failed.

Besides, How do I run bodytrack using openMP via parsecmgmt?

Best Regards,
Huan Fang

_______________________________________________
parsec-users mailing list
parsec-users at lists.cs.princeton.edu
https://lists.cs.princeton.edu/mailman/listinfo/parsec-users



More information about the parsec-users mailing list