[parsec-users] Dedup and zlib problem

Rafael Asenjo asenjo at uma.es
Wed Aug 12 07:16:00 EDT 2009


Hi Amittai,

I found your post in the parsec-users list. I'm heading the same  
problem that you reported in june. My system has a core 2 duo, ubuntu  
8.1, kernel 2.6.24 and gcc 4.2.4. I've got exactly the same messages  
so I wonder if you found a workaround to get the parsecmngt compile  
zlib.

On the other hand I've managed to build dedup in older linux distros  
(SLES 9 and 10). In these machines I found no problems building dedup.  
However, the resulting dedup is not able to uncompress the files  
previously compressed (also with dedup). A Segmentation fault is  
reported, and gdb points to the zlib uncompress function. I guess I'm  
heading a problem with the libz library (version, compatibility, ...  
don't know), but I have tried many things (linking with libz.a  
directly, using -lz, etc).

If you have any idea, I will really appreciate your help. Thank you  
very much in advance.

Rafa
> Hi Amittai,
>
> You should try to fix those errors yourself. I can't reproduce these  
> errors
> so it's difficult for me to give good advice.
>
> TLS usually means "thread local storage". It's possible that your  
> libraries
> are incompatible because your system is too old. TLS is fairly new  
> and still
> not available everywhere.
>
> The PARSEC framework gives you a lot of freedom concerning which  
> benchmarks
> you can run and build. It's best if you read the documentation  
> first, most
> of your questions will be answered there. The PARSEC tutorial in  
> particular
> deals with a lot of questions concerning practical use.
>
> Best,
> Chris
>
>
> -----Original Message-----
> From: parsec-users-bounces at lists.cs.princeton.edu
> [mailto:parsec-users-bounces at lists.cs.princeton.edu] On Behalf Of  
> Amittai
> Aviram
> Sent: Saturday, June 27, 2009 11:02 AM
> To: PARSEC Users
> Subject: [parsec-users] Zlib build error
>
> Hi!  I have been able to run the complete build (parsec -a build)
> until I got to zlib, at which point I got this error:
>
> /usr/lib/gcc/i586-suse-linux/4.3/../../../../i586-suse-linux/bin/ld:
> errno: TLS definition in /lib/libc.so.6 section .tbss mismatches non-
> TLS reference in libz.a(gzio.o)
> /lib/libc.so.6: could not read symbols: Bad value
> collect2: ld returned 1 exit status
> make: *** [example] Error 1
> [PARSEC] Error: 'env /usr/bin/make' failed.
>
> Any idea what this means and what to do about it?  Can I run the
> benchmarks using the built-in inputs and default options without
> building zlib and without finishing the overall build?
>
> BTW, I also noticed a bunch of messages when the script was building
> zlib that don't make sense to me:
>
> [PARSEC] Copying source code of package zlib.
> [PARSEC] Running 'env ./configure --prefix=/export/home/afa9/
> parsec-2.0/pkgs/libs/zlib/inst/i386-linux.gcc':
> Building static library libz.a version 1.2.3 with /usr/bin/gcc.
> Checking for unistd.h... No.
> Checking whether to use vs[n]printf() or s[n]printf()... using
> s[n]printf()
> Checking for snprintf() in stdio.h... No.
>    WARNING: snprintf() not found, falling back to sprintf(). zlib
>    can build but will be open to possible buffer-overflow security
>    vulnerabilities.
> Checking for return value of sprintf()... No.
>    WARNING: apparently sprintf() does not return a value. zlib
>    can build but will be open to possible string-format security
>    vulnerabilities.
> Checking for errno.h... No.
> Checking for mmap support... No.
> [PARSEC] Running 'env /usr/bin/make':
>
> But of course my system has unistd.h, errno.h, and snprintf in
> stdio.h.  And both snprintf and sprintf certainly do return a value
> (an int).  Why does the test script say all this?  Thanks!
>
>
>
> Amittai Aviram
> Graduate Student in Computer Science
> Yale University
> 646 483 2639
> amittai.aviram at yale.edu
> http://www.amittai.com

__
Rafael Asenjo Plaza
Dept. Arquitectura de Computadores
Complejo Tecnologico Campus de Teatinos
E-29071 MALAGA (SPAIN)
Tel: +34 95 213 27 91
Fax: +34 95 213 27 90
http://www.ac.uma.es/~asenjo


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.cs.princeton.edu/pipermail/parsec-users/attachments/20090812/945aec3c/attachment.htm>


More information about the parsec-users mailing list