[parsec-users] Errors running Parsec benchmarks in M5

ef snorlaxgb at gmail.com
Wed Aug 19 21:26:32 EDT 2009


Hello

I fixed the following issue with Vips (not body track):
"./bodytrack: /usr/lib/libstdc++.so.6: version `CXXABI_1.3.1' not found
(required by ./bodytrack)
./bodytrack: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.9' not found
(required by ./bodytrack)"


The Glib library I was using was not comptabile to the diskimage
version(right?), i am using the precompiled Cross Compiler listed under
m5sim.org,  Previously I have been compling benchmarks with :

LDFLAGS=/alphaev67-unknown-linux-gnu//alphaev67-unknown-linux-gnu/lib/
without a problem

However with x264,facesim,bodytrack,vips (maybe others?) the glibc library
is incomptabile
the Crosscompiler has another library path under:

export
LDFLAGS="-L/alphaev67-unknown-linux-gnu/alphaev67-unknown-linux-gnu/sys-root/lib"

Which is compatible to what m5 needs.

Anyways running Vips I ran into the issue of  "minuw4" is an unimplemented
instruction. You can correct that by adding to  vips and its dependent
libraries  (glib, libxl2, zlibs)
the following Flag:
build_env="CXXFLAGS=\"${CXXFLAGS}  -mcpu=21064\" CFLAGS=\"${CFLAGS}
-mcpu=21064\"  "


Anyways I will go ahead and fix the rest of the glibc dependent benchmarks,
I will post solution and problems here.

Thanks
EF
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.cs.princeton.edu/pipermail/parsec-users/attachments/20090819/fb607e97/attachment.html>


More information about the parsec-users mailing list