[parsec-users] Errors running Parsec benchmarks in M5

Christian Bienia cbienia at CS.Princeton.EDU
Sun Aug 30 14:35:52 EDT 2009


Hi Ef,

 

That looks like an issue with the X Window system. Maybe your need to link
to an additional library on an Alpha machine? I'm not sure how to fix it, I
haven't encountered that error before.

 

- Chris

 

 

From: parsec-users-bounces at lists.cs.princeton.edu
[mailto:parsec-users-bounces at lists.cs.princeton.edu] On Behalf Of ef
Sent: Saturday, August 29, 2009 9:36 PM
To: PARSEC Users
Subject: Re: [parsec-users] Errors running Parsec benchmarks in M5

 

Hello,
I am having some difficulties with ray trace, I am getting the following
errors trying to Cross Compile for Alpha:

/home/efi/parsec-2.1/pkgs/libs/mesa/inst/amd64-linux.gcc-alpha/lib/libGL.a(x
m_span.o):/home/ef/parsec-2.1/pkgs/libs/mesa/obj/amd64-linux.gcc-alpha/src/m
esa/drivers/x11/xm_span.c:273: more undefined references to `XDrawPoint'
follow
/home/ef/parsec-2.1/pkgs/libs/mesa/inst/amd64-linux.gcc-alpha/lib/libGL.a(xm
_span.o): In function `put_row_TRUEDITHER_pixmap':
/home/ef/parsec-2.1/pkgs/libs/mesa/obj/amd64-linux.gcc-alpha/src/mesa/driver
s/x11/xm_span.c:284: undefined reference to `XPutImage'
/home/ef/parsec-2.1/pkgs/libs/mesa/obj/amd64-linux.gcc-alpha/src/mesa/driver
s/x11/xm_span.c:284: undefined reference to `XPutImage'
/home/ef/parsec-2.1/pkgs/libs/mesa/inst/amd64-linux.gcc-alpha/lib/libGL.a(xm
_span.o): In function `put_row_rgb_TRUECOLOR_pixmap':
/home/ef/parsec-2.1/pkgs/libs/mesa/obj/amd64-linux.gcc-alpha/src/mesa/driver
s/x11/xm_span.c:238: undefined reference to `XDrawPoint'
Do you have any ideas whats going on? These X* labels are related to -lX11
but they should be recognized, am I reconfiguring mesa wrong or perhaps
raytrace?
Here are my configs for those:

Mesa:
build_env="  LIBS=\"${LIBS}  -lX11  \" CXXFLAGS=\"${CXXFLAGS}  -lX11  \"
CFLAGS=\"${CFLAGS}  -lX11  \" " (just trying to get it to compile)
build_conf="--with-driver=xlib --enable-glut --enable-static
--disable-shared --host=i386-linux --enable-debug"

Raytrace:
build_env="CXXFLAGS=\"-I${PARSECDIR}/pkgs/libs/mesa/inst/${PARSECPLAT}/inclu
de ${CXXFLAGS} -fexceptions -fno-strict-aliasing -fno-align-labels -DNDEBUG
-D_MM_NO_ALIGN_CHECK\"
LDFLAGS=\"-L${PARSECDIR}/pkgs/libs/mesa/inst/${PARSECPLAT}/lib ${LDFLAGS}\"
LIBS=\"${LIBS} -lXmu -lX11 -lGL -lGLU -lpthread -lXext -lXau -ldl \""


Thanks,
EF

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.cs.princeton.edu/pipermail/parsec-users/attachments/20090830/64a6a27f/attachment.html>


More information about the parsec-users mailing list