[parsec-users] Fluianimate Runtime error

Wael Kdouh waelkdouh at gmail.com
Tue Jun 30 16:49:54 EDT 2009


Chris sorry to shift from the main topic of this thread, but when I
 installed the benchmark I unzipped the archived input file within the same
directory. Now I never thought about the installation process of the input
until you raised the issue. Please let me know if unzipping the archive in
the first place was the right thing to do.
You mentioned that parsecmgmt should tell me that it is unpacking the
archive with the input. For instance when I ran blackscholes  on a 16 core
machine I got  the following:

[parsec] setting up run directory
pushd error retrieving current directory: getcwd : cannot access parent
directories. No such file or directory.
[parsec] no archive for input 'simlarge' available, skipping input setup.
[parsec] running 'time
/parsec-2.0/pkgs/apps/blackscholes/inst/sparc-solaris.gcc
[parsec] [-----------------beginning of output ----------------------]
Parsec benchmark suite version 2
[Hooks] parsec hooks version 1.2
Num of options 65536
Num of runs 100
Size of data 2621440
[Hooks]Entering ROI
[Hooks]Leaving ROI
[Hook] Total time spent in Roi: 0.146 sec

real 0.189 s
user 2.355 s
sys  0.007 s

[parsec] end of output
/parsec-2.0/bin/parsecmgmt: line 943: popd: directory stack empty
[parsec] Done

Chris I thought in the past that the above was a successful run since it
generated time, but since you mentioned the unarchiving step, which in the
above example does not seem successful, it made me realize that I may need
to reconsider installing the input in the right way. Could you please let me
know if the above run is indeed an unsuccessful run. If this is the case
could you please provide me with some insight on installing the input.





2009/6/30 Christian Bienia <cbienia at cs.princeton.edu>

>  Wael,
>
>
>
> It appears that the program failed to open the file with the input data.
> Have you installed the simulation inputs correctly? Parsecmgmt should tell
> you that it is unpacking the archive with the input.
>
>
>
> - Chris
>
>
>
>
>
> *From:* parsec-users-bounces at lists.cs.princeton.edu [mailto:
> parsec-users-bounces at lists.cs.princeton.edu] *On Behalf Of *Wael Kdouh
> *Sent:* Tuesday, June 30, 2009 3:55 PM
> *To:* parsec-users at lists.cs.princeton.edu
> *Subject:* [parsec-users] Fluianimate Runtime error
>
>
>
> Hi I am trying to use parsec with Simics version
> 3.0.3. I am simulating a solaris/sparc machine with GCC 4.2
> installed. I managed to compile fluidanimate with the gcc-hooks
> configuration to use the magic break point capability within simics. But
> when I run it I get the following error:
>
>
>
> Assertion failed: file, file pthreads.cpp, line 185
>
> /parsec-2.0/bin/parsecmgmt: line 910: 15925 Abort (core dumped)
>
>
>
> Any insight would be highly appreciated.
>
>
>
> _______________________________________________
> parsec-users mailing list
> parsec-users at lists.cs.princeton.edu
> https://lists.cs.princeton.edu/mailman/listinfo/parsec-users
>
>


-- 
Sincerely yours,

Wael Kdouh
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.cs.princeton.edu/pipermail/parsec-users/attachments/20090630/f818cf98/attachment.htm>


More information about the parsec-users mailing list