[parsec-users] Problem compiling vips

jcupitt at gmail.com jcupitt at gmail.com
Mon Mar 30 06:29:55 EDT 2009


Hi, I'm one of the VIPS maintainers.

2009/3/30 Thomas Karcher <karcher at ipd.uka.de>:
> Apparently, this comes from binding with gcc instead of g++. I can
> reproduce the same error when I compile vips manually with the
> same ./configure line. And I can manually run the failing command line
> by substituting gcc with g++.
>
> However, if I remove the "--disable-shared" option (when compiling
> manually), it works.

Could you post the configure line that fails? I just tried:

$ ./configure --prefix=/home/john/vips --disable-shared
$ make install > make.log
$ ls /home/john/vips/lib
libvips.a  libvipsCC.a  libvipsCC.la  libvips.la  pkgconfig  python2.5

This is Ubuntu 8.10, vips SVN trunk, if that makes a differrence.

John


More information about the parsec-users mailing list