[parsec-users] Problem compiling vips

Thomas Karcher karcher at ipd.uka.de
Mon Mar 30 06:58:31 EDT 2009


Hi John,

> Hi, I'm one of the VIPS maintainers.

Wow - nice to meet you :)

> > Apparently, this comes from binding with gcc instead of g++. I can
> > reproduce the same error when I compile vips manually with the
> > same ./configure line. And I can manually run the failing command line
> > by substituting gcc with g++.
> > However, if I remove the "--disable-shared" option (when compiling
> > manually), it works.
> Could you post the configure line that fails? I just tried:
> $ ./configure --prefix=/home/john/vips --disable-shared
> $ make install > make.log
> $ ls /home/john/vips/lib
> libvips.a  libvipsCC.a  libvipsCC.la  libvips.la  pkgconfig  python2.5
> This is Ubuntu 8.10, vips SVN trunk, if that makes a differrence.

This seems to be vips 7.16.2, from PARSEC 2.0.

This works fine:
==
./configure --without-fftw3 --without-magick --without-liboil
--without-lcms --without-OpenEXR --without-pangoft2 --without-tiff
--without-jpeg --without-zip --without-png --without-libexif
--without-python --without-x --without-perl --without-v4l
--enable-threads
==

This breaks:
==
./configure --disable-shared --without-fftw3 --without-magick
--without-liboil --without-lcms --without-OpenEXR --without-pangoft2
--without-tiff --without-jpeg --without-zip --without-png
--without-libexif --without-python --without-x --without-perl
--without-v4l --enable-threads
==

(Except for --disable-shared, both are the standard PARSEC configure
lines.)


Thanks,
Thomas



More information about the parsec-users mailing list