[parsec-users] parsec benchmark compiling problem

Christian Bienia cbienia at CS.Princeton.EDU
Wed May 27 13:47:28 EDT 2009


Hi Jerry,

 

It appears the typical standard Unix tools cannot be found. The script tells
you what is missing: "env: No such file or directory". Try to type "env" at
your command prompt to see whether it can is available. It might be that the
directory with the executable is simply not in your path, so check your PATH
environment variable, too.

 

You either need to fix your environment or try to build PARSEC manually
(without the parsecmgmt script).

 

- Chris

 

 

From: parsec-users-bounces at lists.cs.princeton.edu
[mailto:parsec-users-bounces at lists.cs.princeton.edu] On Behalf Of Jerry Lin
Sent: Wednesday, May 27, 2009 12:19 AM
To: parsec-users at lists.cs.princeton.edu
Subject: [parsec-users] parsec benchmark compiling problem

 

Hi all,


  I tried to run parsec benchmark on Solaris10 simulated by Simics 3.0.31
and Gems 2.1.


Because the simulated machine doesn't support co-processor operation used in
downloaded









PARSEC Binaries for Solaris/Sparc.


So I tried to compile the source code.


But I encounter a problem when compiling all the benchmark.

The following is the error message
==============================================
bash-3.00# ./parsecmgmt -a build -p freqmine    
[PARSEC] Packages to build:  freqmine

[PARSEC] [========== Building package freqmine ==========]
[PARSEC] [---------- Analyzing package freqmine ----------]
[PARSEC] freqmine does not depend on any other packages.
[PARSEC] [---------- Building package freqmine ----------]
[PARSEC] Copying source code of package freqmine.
[PARSEC] Running 'env /usr/sfw/bin/make':
env: No such file or directory
[PARSEC] Error: 'env /usr/sfw/bin/make' failed.
==============================================

Did I do something wrong? How can I fix this problem?
Thanks for helping.
 
Jerry 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.cs.princeton.edu/pipermail/parsec-users/attachments/20090527/c6172d69/attachment.html>


More information about the parsec-users mailing list