[parsec-users] streamcluster hangs

Amittai Aviram amittai.aviram at yale.edu
Sat Oct 17 02:46:56 EDT 2009


I am finding that streamcluster consistently hangs on my machine right  
after printing the output line giving the number of points read.   
E.g., for the default input size (small--10 points), and 2 threads, I  
get the following:

[After building with -c gcc-pthreads, apparently successfully ...]

afa9 at beacon:~/parsec-2.0-dthreads> parsecmgmt -a run -p streamcluster - 
c gcc-pthreads -n 2
[PARSEC] Benchmarks to run:  streamcluster

[PARSEC] [========== Running benchmark streamcluster ==========]
[PARSEC] Deleting old run directory.
[PARSEC] Setting up run directory.
[PARSEC] No archive for input 'test' available, skipping input setup.
[PARSEC] Running 'time /export/home/afa9/parsec-2.0-dthreads/pkgs/ 
kernels/streamcluster/inst/i386-linux.gcc-pthreads/bin/streamcluster 2  
5 1 10 10 5 none output.txt 2':
[PARSEC] [---------- Beginning of output ----------]
PARSEC Benchmark Suite Version 2.0
read 10 points
^C <-------------------------HANGS, HAD TO KILL

I've gotten the same behavior on 16 and 64 threads and on the  
"simlarge" input.  If I do not enter a thread number, so that it  
defaults to sequential execution, then the program does terminate.

I'm running the benchmarks under 32-bit Open Suse 11 (Linux) on an  
Intel (i686) machine.

Any ideas?  Did I miss or forget something from the tutorial or other  
documentation?  Thanks!

Amittai Aviram
Graduate Student in Computer Science
Yale University
646 483 2639
amittai.aviram at yale.edu

More information about the parsec-users mailing list