[parsec-users] compiling problem for bodytrack, facesim and x264

Christian Bienia cbienia at CS.Princeton.EDU
Mon Aug 16 14:58:06 EDT 2010


Hi Ning Deng,

 

I suspect that your build environment on Solaris is broken. I had to rebuild
gcc from scratch to get a working compiler that could build all of PARSEC.
For example, the last error that you list (wrong ELFCLASS) indicates that
the linker which gets invoked by the compiler doesn't handle the binary
format correctly. I remember I also got this error at some point on Solaris.

 

My suggestion is you rebuild your build environment from scratch. Check the
various Internet sources where people talk about the issues they had when
they tried to get gcc to work on Solaris. You can also have a look at the
FAQ file that comes with PARSEC 2.1 where I documented some of the things I
did to build PARSEC on Solaris.

 

If all else fails you can also use the precompiled PARSEC binaries which I
created for Solaris.

 

Best,

Chris

 

 

 

From: parsec-users-bounces at lists.cs.princeton.edu
[mailto:parsec-users-bounces at lists.cs.princeton.edu] On Behalf Of ??
Sent: Monday, August 16, 2010 1:35 AM
To: parsec-users at lists.cs.princeton.edu
Subject: [parsec-users] compiling problem for bodytrack, facesim and x264

 

Hi, 

I tried to build the packages one by one. For the reason of package
dependencies, I skipped applications like ferret, raytrace, vips and dedup
that need extra packages. I compiled the packages: blackscholes, bodytrack,
facesim, fluidanimate, freqmine, swaptions, x264, canneal and streamcluster.
There are some problem when compiling following packages, I paste the error
message for diagnosis:

1. bodytrack[FAILED]
checking whether we are using the GNU C++ compiler... (cached) yes 
checking whether /usr/sfw/bin/g++ accepts -g... (cached) yes 
cat: cannot open confdefs.h 
cat: cannot open confdefs.h 
cat: cannot open confdefs.h 
cat: cannot open confdefs.h 
checking dependency style of /usr/sfw/bin/g++... (cached) gcc3 
checking for a BSD-compatible install...
/host/home/dengning/parsec-2.1/bin/../bin/install -c 
checking whether ln -s works... no, using ln 
checking whether /usr/sfw/bin/gmake sets $(MAKE)... (cached) yes 
checking for main in -lpthread... yes 
checking pthread.h usability... yes 
checking pthread.h presence... no 
configure: WARNING: pthread.h: accepted by the compiler, rejected by the
preprocessor! 
configure: WARNING: pthread.h: proceeding with the compiler's result 
checking for pthread.h... yes 
checking for stdint.h... (cached) yes 
checking for ANSI C header files... (cached) yes 
checking for stdbool.h that conforms to C99... no 
checking for _Bool... yes 
checking whether time.h and sys/time.h may both be included... yes 
checking for an ANSI C-conforming const... yes 
checking for inline... inline 
checking for stdlib.h... (cached) yes 
checking for GNU libc compatible malloc... no 
checking for memset... yes 
checking for sqrt... no 
configure: creating ./config.status 
[PARSEC] Error: Cannot find Makefile in
/host/home/dengning/parsec-2.1/bin/../pkgs/apps/bodytrack/obj/sparc-solaris.
gcc 
bash-3.00# 

2. facesim[FAILED]
/usr/sfw/bin/g++ -c -O3 -funroll-loops -fpermissive -fno-exceptions -m64
-I/usr/sfw/include -DPARSEC_VERSION=2.1 -fexceptions
-I/host/home/dengning/parsec-2.1/bin/../pkgs/apps/facesim/obj/sparc-solaris.
gcc/TaskQ/include -DUSE_ALAMERE_TASKQ -w  -DNDEBUG -o
obj/Collisions_And_Interactions/BOX_HIERARCHY.o
Collisions_And_Interactions/BOX_HIERARCHY.cpp 
/usr/sfw/bin/g++ -c -O3 -funroll-loops -fpermissive -fno-exceptions -m64
-I/usr/sfw/include -DPARSEC_VERSION=2.1 -fexceptions
-I/host/home/dengning/parsec-2.1/bin/../pkgs/apps/facesim/obj/sparc-solaris.
gcc/TaskQ/include -DUSE_ALAMERE_TASKQ -w  -DNDEBUG -o
obj/Collisions_And_Interactions/COLLISION_BODY_LIST_3D.o  
g++: no input files 
gmake[2]: *** [obj/Collisions_And_Interactions/COLLISION_BODY_LIST_3D.o]
Error 1 
gmake[2]: Leaving directory
`/host/home/dengning/parsec-2.1/pkgs/apps/facesim/obj/sparc-solaris.gcc/Publ
ic_Library' 
gmake[1]: *** [BUILD_PhysBAM] Error 2 
gmake[1]: Leaving directory
`/host/home/dengning/parsec-2.1/pkgs/apps/facesim/obj/sparc-solaris.gcc/Benc
hmarks/facesim' 
gmake: *** [all] Error 2 
[PARSEC] Error: 'env
PHYSBAM=/host/home/dengning/parsec-2.1/bin/../pkgs/apps/facesim/obj/sparc-so
laris.gcc CXXFLAGS=-O3 -funroll-loops -fpermissive -fno-exceptions -m64
-I/usr/sfw/include -DPARSEC_VERSION=2.1 -fexceptions /usr/sfw/bin/gmake'
failed. 
bash-3.00# 

3. x264[FAILED]
ld:fatal: file x264.o:wrong ELF class: ELFCLASS64
ld:fatal: File processing errors. No output written to x264
collect2: ld returned 1 exit status
gmake: *** [x264] Error 1

Can anyone give me some hints?  Thanks in advance.

-- 
Regards
Ning Deng

School Of Computer Science and Technology 
Beijng Institute of Technology, China, 100081
dunning2006 at gmail.com

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.cs.princeton.edu/pipermail/parsec-users/attachments/20100816/317d880f/attachment.html>


More information about the parsec-users mailing list