[parsec-users] Building PARSEC2.1

Tanima Dey dey_trina at yahoo.com
Sat Jan 9 18:03:01 EST 2010


Hi,
I have been working with PARSEC1.0 and today I started to work with the latest version, PARSEC2.1. I am building the benchmark in the same way as I did for PARSEC1.0 but it keeps showing me the following error message.

td8h at sunfire1
: /af5/td8h/parsec-2.1/bin ; ./parsecmgmt -a build -p blackscholes
[PARSEC] Packages to build:  blackscholes

[PARSEC] [========== Building package blackscholes ==========]
[PARSEC] [---------- Analyzing package blackscholes ----------]
[PARSEC] blackscholes does not depend on any other packages.
[PARSEC] [---------- Building package blackscholes ----------]
[PARSEC] Copying source code of package blackscholes.
[PARSEC] Running 'env version=pthreads /usr/bin/make':
rm -f blackscholes  blackscholes.m4.cpp
/usr/bin/m4 ./c.m4.pthreads blackscholes.c > blackscholes.m4.cpp
/n/fs/parsec/local/gcc-4.4.0-static/bin/g++ -O3 -funroll-loops -fprefetch-loop-arrays -fpermissive -fno-exceptions -static-libgcc -Wl,--hash-style=both,--as-needed -DPARSEC_VERSION=2.1 -pthread -DENABLE_THREADS -DN=960 -DNCO=4   blackscholes.m4.cpp -L/n/fs/parsec/local/gcc-4.4.0-static/lib64 -L/n/fs/parsec/local/gcc-4.4.0-static/lib  -o blackscholes 
make: /n/fs/parsec/local/gcc-4.4.0-static/bin/g++: Command not found
make: *** [blackscholes] Error 127
[PARSEC] Error: 'env version=pthreads /usr/bin/make' failed.

usually when I ran these benchmarks, it uses /usr/bin/g++, but now it is trying to use "/n/fs/parsec/local/gcc-4.4.0-static/bin/g++" which is not found and I think this is why the benchmarks are failing. By the way, I am building the benchmarks on Intel Xeon machines.

Can anyone help please?

Thanks
Tanima.



      
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.cs.princeton.edu/pipermail/parsec-users/attachments/20100109/642dd625/attachment.html>


More information about the parsec-users mailing list