[parsec-users] xext lib error when building PARSEC

Christian Bienia cbienia at CS.Princeton.EDU
Thu Jul 1 10:38:36 EDT 2010


Hi Ke,

 

I don't know the library or what this error means. Here is what you can do:

 

1.       Try to build the mesa library without the PARSEC framework. Mesa is
an open-source implementation of the OpenGL specification. You can also go
to their mailing lists to get help for that, they will probably be able to
help you more.

2.       You might already have an OpenGL implementation on your system, or
you should be able to get one easily. You can link to that with raytrace.
The only thing to look out for is to make sure that your OpenGL
implementation does the rendering in software - your simulator probably does
not support a GPU.

 

Best,

Chris

 

 

From: parsec-users-bounces at lists.cs.princeton.edu
[mailto:parsec-users-bounces at lists.cs.princeton.edu] On Behalf Of Ke Chen
Sent: Wednesday, June 30, 2010 11:57 PM
To: parsec-users at lists.cs.princeton.edu
Subject: [parsec-users] xext lib error when building PARSEC

 

Hi All,

I had trouble building PARSEC on Ubuntu 10.04 when building package
raytrace.  The log displayed in the shell is listed below with the error
message highlighted.  

I have already installed the xext lib, by installing x11proto-xext-dev
package in the Synaptic Package Manager.  And I also tried to modify the
PKG_CONFIG_PATH to /usr/lib where the xext lib is supposed to be installed.
But there is still the same error. 

If you have the same problem before, please give me a hand to solve it.
Thank you for helping.

____________________________________________________________________________
__________________________
kechen at ubuntu:~/PARSEC/parsec-2.1/bin$ ./parsecmgmt -a build -p all[PARSEC]
Packages to build:  blackscholes bodytrack facesim ferret freqmine raytrace
swaptions fluidanimate vips x264 canneal dedup streamcluster glib gsl hooks
imagick libxml2 ssl tbblib mesa zlib cmake libtool yasm

[PARSEC] [========== Building package raytrace ==========]
[PARSEC] [---------- Analyzing package raytrace ----------]
[PARSEC] raytrace depends on: cmake mesa
[PARSEC] [---------- Analyzing package cmake ----------]
[PARSEC] Package cmake already exists, proceeding.
[PARSEC] [---------- Analyzing package mesa ----------]
[PARSEC] mesa does not depend on any other packages.
[PARSEC] [---------- Building package mesa ----------]
[PARSEC] Removing old build directory.
[PARSEC] Copying source code of package mesa.
[PARSEC] Running 'env ./configure --with-driver=xlib --enable-glut
--enable-static --disable-shared
--prefix=/home/kechen/PARSEC/parsec-2.1/bin/../pkgs/libs/mesa/inst/amd64-lin
ux.gcc':
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking for gcc... /usr/bin/gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables... 
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether /usr/bin/gcc accepts -g... yes
checking for /usr/bin/gcc option to accept ISO C89... none needed
checking how to run the C preprocessor... /usr/bin/cpp
checking for gcc... (cached) /usr/bin/gcc
checking whether we are using the GNU C compiler... (cached) yes
checking whether /usr/bin/gcc accepts -g... (cached) yes
checking for /usr/bin/gcc option to accept ISO C89... (cached) none needed
checking whether we are using the GNU C++ compiler... yes
checking whether /usr/bin/g++ accepts -g... yes
checking for gmake... /usr/bin/make
checking for makedepend... no
checking for sed... /bin/sed
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking whether to enable assembly... yes, x86
checking for dlopen... no
checking for dlopen in -ldl... yes
checking for posix_memalign... yes
checking pkg-config files for X11 are available... yes
checking for XLIBGL... configure: error: Package requirements (x11 xext)
were not met:

No package 'xext' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables XLIBGL_CFLAGS
and XLIBGL_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

[PARSEC] Error: 'env ./configure --with-driver=xlib --enable-glut
--enable-static --disable-shared
--prefix=/home/kechen/PARSEC/parsec-2.1/bin/../pkgs/libs/mesa/inst/amd64-lin
ux.gcc' failed.

-- 
Ke Chen
Graduate Student - Department of Electrical Engineering
University of Notre Dame

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.cs.princeton.edu/pipermail/parsec-users/attachments/20100701/d915b422/attachment.htm>


More information about the parsec-users mailing list