[parsec-users] Dedup, Memory allocation failed

Mahmood Naderan nt_mahmood at yahoo.com
Mon Jul 26 01:46:15 EDT 2010


> I am seeing the same error
 
>You need about 4 -8 GB of memory to run dedup

Yes 8GB works fo me also. Thanks,

// Naderan *Mahmood;




________________________________
From: Joel Hestness <hestness at cs.utexas.edu>
To: PARSEC Users <parsec-users at lists.cs.princeton.edu>
Sent: Sun, July 25, 2010 9:06:41 PM
Subject: Re: [parsec-users] Dedup, Memory allocation failed

Hi, 
  Are you compiling this for x86_64 perchance?  If so, I am seeing the same 
error when running dedup in the M5 simulator under X86_FS, so I can confirm the 
bug.
  Any ideas what it is?  Which memory allocation in the program?
  Thanks,
  Joel




2010/7/25 Mahmood Naderan <nt_mahmood at yahoo.com>

Hi all,
>For Dedup, I get a memory error for all of the data sets. Here is an example:
>
>bash-3.00# ./dedup  -i hamlet.dat -o hamlet.out -t 1
>PARSEC Benchmark Suite Version 2.1
>[HOOKS] PARSEC Hooks Version 1.2
>[HOOKS] Entering ROI
>[DataProcess] Memory allocation failed.
>bash-3.00# vmstat
> kthr      memory            page            disk          faults      cpu
> r b w   swap  free  re  mf pi po fr de sr s0 s1 s6 --   in   sy   cs us sy id
> 1 0 0 1131968 843504 92 340 174 2 2  0 21  4 28 205 0  739 5175 1531 64 35  1
>
>  
>I increased the memory from 512MB to 1GB and still get the same error.
>Thanks,
>
>// Naderan *Mahmood;
>
>_______________________________________________
>parsec-users mailing list
>parsec-users at lists.cs.princeton.edu
>https://lists.cs.princeton.edu/mailman/listinfo/parsec-users
>
>


-- 
  Joel Hestness
  PhD Student, Computer Architecture
  Dept. of Computer Science, University of Texas - Austin
  http://www.cs.utexas.edu/~hestness



      
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.cs.princeton.edu/pipermail/parsec-users/attachments/20100725/51230ff1/attachment-0001.html>


More information about the parsec-users mailing list