[parsec-users] No Makefile for bodytrack

Christian Bienia cbienia at CS.Princeton.EDU
Tue Jun 1 16:35:10 EDT 2010


Hi Mahmood,

 

The Makefile.am and Makefile.in are used by configure to generate the actual Makefile. It’s part of GNU automake.

 

I’m not sure why it doesn’t work on your system, you’ll probably have to debug that yourself. The steps executed by parsecmgmt for all PARSEC packages are as follows:

 

1.)    If no Makefile exists, run “configure” script in src/ directory with arguments from run configuration to create it.

2.)    Run “make” which will use the Makefile generated by configure.

3.)    Run “make install”

 

These are the standard GNU autoconf and automake tools that are popular with many open source software projects. You can download any of the GNU open source software to give it a try with another software to learn how to use it. Here are some more explanations:

 

http://www.la-samhna.de/library/compile/configure.html

 

I think it’s best if you replicate the steps that parsecmgmt performs manually. The description I gave above and in my other mails might be helpful, for further questions you should either look at the PARSEC tutorial which describes everything in more detail or read the source code of parsecmgmt yourself. There’s not much I can do to help you, it works fine on my system.

 

Best,

Chris

 

 

From: parsec-users-bounces at lists.cs.princeton.edu [mailto:parsec-users-bounces at lists.cs.princeton.edu] On Behalf Of Mahmood Naderan
Sent: Tuesday, June 01, 2010 5:02 AM
To: PARSEC Users
Subject: Re: [parsec-users] No Makefile for bodytrack

 

Chris,
I read your post at https://lists.cs.princeton.edu/pipermail/parsec-users/2008-April/000053.html. 
I checked some packages and found that they have Makefile.am and Makefile.in instead of Makefile. Don't you think it is the root of problem?

 

// Naderan *Mahmood;

 

 

  _____  

From: Mahmood Naderan <nt_mahmood at yahoo.com>
To: PARSEC Users <parsec-users at lists.cs.princeton.edu>
Sent: Tue, June 1, 2010 12:22:13 PM
Subject: Re: [parsec-users] No Makefile for bodytrack

I extracted the bodytrack from the original tar file and here is the content:

mahmood at localhost:bodytrack$ ls -R
.:
inputs  parsec  src  version

./inputs:
COPYRIGHT  input_native.tar  input_simdev.tar  input_simlarge.tar  input_simmedium.tar  input_simsmall.tar  input_test.tar  LICENSE

./parsec:
gcc.bldconf        gcc-openmp.bldconf    gcc-serial.bldconf  icc.bldconf     simdev.runconf    simmedium.runconf  test.runconf
gcc-hooks.bldconf  gcc-pthreads.bldconf  gcc-tbb.bldconf     native.runconf  simlarge.runconf  simsmall.runconf

./src:
aclocal.m4      ChangeLog     config.sub    COPYING       INSTALL     Makefile.am  NEWS               TrackingBenchmark.sln
AUTHORS         config.guess  configure     depcomp       install-sh  Makefile.in  README
autom4te.cache  config.h.in   configure.ac  FlexImageLib  ltmain.sh   missing      TrackingBenchmark

./src/autom4te.cache:
output.0  output.1  requests  traces.0  traces.1

./src/FlexImageLib:
BinaryImage.h       FlexDefs.h    FlexImage.cpp        FlexImageLib.vcproj  FlexIO.cpp  FlexOperators.h  Makefile.am
FlexColor.h         FlexDraw.h    FlexImage.h          FlexImageStatus.h    FlexIO.h    FlexThreshold.h  Makefile.in
FlexDataExchange.h  FlexFilter.h  FlexImageLib.icproj  FlexImageStore.h     FlexLib.h   FlexTransform.h

./src/TrackingBenchmark:
AnnealingFactor.cpp  BodyPose.h             ImageMeasurements.h  ParticleFilterOMP.h      TBBtypes.h                TrackingModelOMP.h
AnnealingFactor.h    CameraModel.cpp        ImageProjection.cpp  ParticleFilterPthread.h  threads                   TrackingModelPthread.cpp
AsyncIO.cpp          CameraModel.h          ImageProjection.h    ParticleFilterTBB.h      TrackingBenchmark.icproj  TrackingModelPthread.h
AsyncIO.h            CovarianceMatrix.cpp   main.cpp             RandomGenerator.cpp      TrackingBenchmark.vcproj  TrackingModelTBB.cpp
BodyGeometry.cpp     CovarianceMatrix.h     Makefile.am          RandomGenerator.h        TrackingModel.cpp         TrackingModelTBB.h
BodyGeometry.h       DMatrix.h              Makefile.in          SmallVectors.h           TrackingModel.h           Vector3.h
BodyPose.cpp         ImageMeasurements.cpp  ParticleFilter.h     system.h                 TrackingModelOMP.cpp      WorkPoolPthread.h

./src/TrackingBenchmark/threads:
atomic       Barrier.h      Condition.h  Makefile.am  Mutex.cpp  RWLock.cpp  SynchQueue.h  ThreadGroup.cpp  Thread.h           WorkerGroup.cpp
Barrier.cpp  Condition.cpp  LockTypes.h  Makefile.in  Mutex.h    RWLock.h    Thread.cpp    ThreadGroup.h    TicketDispenser.h  WorkerGroup.h

./src/TrackingBenchmark/threads/atomic:
amd64  atomic.h  i386  ia64  powerpc  sparc

./src/TrackingBenchmark/threads/atomic/amd64:
atomic.h

./src/TrackingBenchmark/threads/atomic/i386:
atomic.h

./src/TrackingBenchmark/threads/atomic/ia64:
atomic.h

./src/TrackingBenchmark/threads/atomic/powerpc:
atomic.h  cpufunc.h

./src/TrackingBenchmark/threads/atomic/sparc:
asi.h  atomic.h  cpufunc.h


But still get the same error:
checking for GNU libc compatible malloc... no
checking for memset... yes
checking for sqrt... no
configure: creating ./config.status
[PARSEC] Error: Cannot find Makefile in /host/home/mahmood/PARSEC/parsec-2.1/bin
/../pkgs/apps/bodytrack/obj/sparc-solaris.gcc

 
Thanks for any help.

// Naderan *Mahmood;

 

 

  _____  

From: Christian Bienia <cbienia at CS.Princeton.EDU>
To: PARSEC Users <parsec-users at lists.cs.princeton.edu>
Sent: Tue, June 1, 2010 10:14:21 AM
Subject: Re: [parsec-users] No Makefile for bodytrack

Mahmood,

 

There’s a standard GNU autoconf configure script that needs to get executed to create the Makefile. Parsecmgmt does that automatically. If it doesn’t on your system you messed either with the script or with the bodytrack source tree.

 

- Chris

 

 

From: parsec-users-bounces at lists.cs.princeton.edu [mailto:parsec-users-bounces at lists.cs.princeton.edu] On Behalf Of Mahmood Naderan
Sent: Tuesday, June 01, 2010 1:19 AM
To: PARSEC
Subject: [parsec-users] No Makefile for bodytrack

 

Dear all,
Does anybody encounter this error while building bodytrack with "./parsecmgmt -a build -p bodytrack"?

[PARSEC] Error: Cannot find Makefile in ../pkgs/apps/bodytrack/obj/sparc-solaris.gcc

And really there is no makefile there. 
 

// Naderan *Mahmood;

 

 

 

 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.cs.princeton.edu/pipermail/parsec-users/attachments/20100601/a354dc56/attachment.htm>


More information about the parsec-users mailing list