[parsec-users] build error

lulu he loloseed at gmail.com
Sun Jun 6 21:55:02 EDT 2010


Hi,

I got a build error here.

It seems the error is here:
/usr/local/bin/g++ -O3 -funroll-loops -fprefetch-loop-arrays -fpermissive
-fno-exceptions -static-libgcc -Wl, --hash-style=both -Wl, --as-needed
-DPARSEC_VERSION=2.1 -fexceptions -Wall -Wno-unknown-pragmas -o bodytrack
AnnealingFactor.o BodyGeometry.o BodyPose.o CameraModel.o CovarianceMatrix.o
ImageMeasurements.o ImageProjection.o RandomGenerator.o TrackingMode.o
main.o TrackingModelPthread.o AsyncIO.o -L/usr/local/lib64 -L/usr/local/lib
../FlexImageLib/.libs/libflex.a
-L/home/hll/simplescalar/gcc-3.2.2/x86_64-unknown-linux-gnu/libstdc++-v3/src
-L/home/hll/simplescalar/gcc-3.2.2/x86_64-unknown-linux-gnu/libstdc++-v3/src/.libs
-L/home/hll/simplescalar/gcc-3.2.2/gcc threads/.libs/libthreads.a
/usr/local/lib/../lib64/libstdc++.so -L/lib/../lib64 -L/usr/lib../lib64 -lm
-lc -lgcc_s -lphread

you can see
here: -L/home/hll/simplescalar/gcc-3.2.2/x86_64-unknown-linux-gnu/libstdc++-v3/src
-L/home/hll/simplescalar/gcc-3.2.2/x86_64-unknown-linux-gnu/libstdc++-v3/src/.libs
-L/home/hll/simplescalar/gcc-3.2.2/gcc threads/.libs/libthreads.a

I once built the gcc3.2.2 from simplescalar, but I really don't want to use
that compiler when build PARSEC.

but 'g++ -v ' command shows the gcc version is 4.2.4

could you tell me how to reconfig the parsecmgmt to use gcc43 lib for
building???

-- 
LuLu He
Cluster and Grid Computing Lab (CGCL)
Services Computing Technology and System Lab (SCTS)
School of Computer Science and Technology (CS)
Huazhong University of Science and Technology (HUST)
Wuhan, 430074, China
Email: loloseed at gmail.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.cs.princeton.edu/pipermail/parsec-users/attachments/20100607/f24f41ac/attachment.html>


More information about the parsec-users mailing list