[parsec-users] Running a benchmark without ./parsecmgmt

Mahmood Naderan nt_mahmood at yahoo.com
Mon May 31 15:10:09 EDT 2010

Hi again,
with a simple command "export LD_LIBRARY_PATH=/usr/local/lib", that problem solved. 
bash-3.00# ./blackscholes
PARSEC Benchmark Suite Version 2.1
        ./blackscholes <nthreads> <inputFile> <outputFile>

So I extracted one of the input files and run:
bash-3.00# ./blackscholes 2 in_4K.txt in_4K.out
PARSEC Benchmark Suite Version 2.1
Num of Options: 4096
Num of Runs: 100
Size of data: 163840

All thing are fine now. One more question then: What is the <nthreads>? Running the benchmark with ./parsecmgmt does not need any <nthreads>. Why it is mandatory here?
// Naderan *Mahmood;

From: Christian Bienia <cbienia at CS.Princeton.EDU>
To: PARSEC Users <parsec-users at lists.cs.princeton.edu>
Sent: Mon, May 31, 2010 10:46:01 PM
Subject: Re: [parsec-users] Running a benchmark without ./parsecmgmt

Hi Mahmood,
The error message means that your dynamic linker can’t find the required shared libraries that are compatible with the ones that were used to build the program. In this case it’s the C++ standard library that comes with your compiler. If you can run the program with parsecmgmt then that means your compiler with its libraries is installed in a non-standard location about which the dynamic linker doesn’t know. You need to manually tell your dynamic linker where the libraries can be found, please check the documentation for LD_LIBRARY_PATH (or any other way) to see how to do that.
Parsecmgmt executes the following steps to run a program, you need to replicate them somehow if you want to run programs manually:
1.)    Create working directory, unpack any program inputs there
2.)    Set paths to shared libraries needed by the program
3.)    Get arguments to use from run configurations
4.)    Change to working directory
5.)    Execute program binaries with correct arguments
From:parsec-users-bounces at lists.cs.princeton.edu [mailto:parsec-users-bounces at lists.cs.princeton.edu] On Behalf Of Mahmood Naderan
Sent: Monday, May 31, 2010 1:41 PM
Subject: [parsec-users] Running a benchmark without ./parsecmgmt
When I run "./parsecmgmt -a run -p blackscholes", there is no problem. However when I enter the obj/... and run the bianry "./blackscholes", I get this error:
ld.so.1: blackscholes: fatal: libstdc++.so.6: open failed: No such file or directory
How can I run the binary without "./parsecmgmt"?
// Naderan *Mahmood;

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.cs.princeton.edu/pipermail/parsec-users/attachments/20100531/8da31ebe/attachment.htm>

More information about the parsec-users mailing list