[parsec-users] Using Pthreadw

Anusha anu.jeya at gmail.com
Mon Nov 29 16:51:09 EST 2010


Hi Chris,

I get the following error when I run the swaptions benchmark with pthreadw

This error was caused during library initialization and is the consequence
of a library dependency cycle. The pthread profiling library uses mangled
pthread symbols during its initialization to provide functionality required
by other libraries, however in the case of 'pthread_mutex_lock' no such
symbol was found.
This could be the result of incorrect symbol mangling, but it might also be
that the pthread library on this system does not have a mangled symbol for
'pthread_mutex_lock', in which case it is not possible to profile that
function on this system with the current combination of libraries. Please
inform the maintainer cbienia at users.sourceforge.net.

- When I ran the bodytrack benchmark with pthreadw, the number of threads is
two more than the number of threads that I specify.

- When I ran the vips benchmark, the number of threads is three more than
the number of threads that I specify.


-Anusha
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.cs.princeton.edu/pipermail/parsec-users/attachments/20101129/f7145d0f/attachment.html>


More information about the parsec-users mailing list