[parsec-users] Request for help

Christian Bienia cbienia at CS.Princeton.EDU
Sun Oct 24 13:20:42 EDT 2010


Hi Nitin,

 

This seems to be an issue with your simulator. From what I can tell you're
using the PARSEC binaries as intended (measurement of ROI, cache warmup,
etc). Let's see whether somebody on this mailing list can help you with your
request. You should also ask your question on the Simics forum and the GEMS
mailing list, they're probably the best source for help for issues like
yours.

 

Best,

Chris

 

 

From: Nitin Chaturvedi [mailto:ntnbits at gmail.com] 
Sent: Sunday, October 24, 2010 2:36 AM
To: parsec-users at lists.cs.princeton.edu
Cc: .; cbienia at CS.Princeton.EDU; li at CS.Princeton.EDU
Subject: Request for help

 

hi friends
i am facing problem to analyze the canneal benchmark statistics(
ruby-dumpstats) attached with this mail.

Following is the procedure 
I executed parsec benchmark on simics+ruby but i am not getting satisfactory
results...............please check .......where i am committing mistake (i
am using precompiled sparc binaries( parsec) and my baseline configuration
(abisko-core-8 + solaris 10 + ruby))


For ROI.
1) What i have done is that fast-forwarded the simulation until the begining
of ROI(i have used solaris10+sparc precompiled binaries)
    a) start simics    ./simics
    b) simics>magic-break-enable
    c) simics>c
    d) Now i ran PARSEC benchmark on abisko console (i used canneal with 8
threads created with precompiled binaries)
        ->Command to run benchmark is as follows: ./parsecmgmt -a run -p
canneal -x pre -i simlarge -c gcc-hooks -n 8
    e) simics will stop execution when it executes magic inst.
    d) Now i written checkpoint using "write-configuration" ( "Cold
checkpoint".)

2)warming up caches

 a)./simics 
 b) read-configuration  coldcheckpoint.conf
 c) instruction-fetch-mode instruction-cache-access-trace (On
sparcv9-----instruction-fetch-

trace is implemented as instruction-cache-access-trace
 d) istc-disable
 e) dstc-disable
 f) @conf.sim.cpu_switch_time = 1
 g) magic-break-enable
 h) load-module ruby 
 i) ruby0.init
 j) c 1
 k) ruby0.tracer-output-file "/home/canneal-simlarge.warmup"
 l) c 10000000
 0) write-configuration /GEMS/simics/home/MOESI_CMP_token/cannelwarmup.conf
(known as "Warm checkpoint")
 p) quit

Till this point every thing worked fine but while doing measurement its
throughing error............please check what i have done
  
3) Measurement
 a) #read cold checkpoint
    read-configuration  cannelwarmup.conf
 b) instruction-fetch-mode instruction-cache-access-trace
 c) istc-disable
 d) dstc-disable
 e) @conf.sim.cpu_switch_time = 1
 f) magic-break-enable
 g) load-module ruby 
 h) ruby0.init
 i) ruby0.load-caches canneal-simlarge.warmup
 j) c
 k) ruby0.dump-stats  cannel
 l) quit

Now when i check dump stats I keep getting around 95% for the L2 cache hit
ratio  for the canneal benchmarks and it shows
L1D_cache_total_misses: 0
L1I_cache_total_misses: 0
L2_cache_total_misses: 19625184

however with simics(g-cache attached i.d default one) i got (around 65% for
all L1 caches and 80% for the L2 cache) 

I've been stuck here for quite some time now since I'm not sure whether I'm
getting the right output or not or i am enable to read it correctly. Please
help me.......

Thanks in advance
with best wishes 
Nitin Chaturvedi
Lecturer, EEE/IU
BITS, Pilani (Raj)



-- 
Nitin Chaturvedi
Lecturer, EEE/IU
BITS, Pilani (Raj)

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.cs.princeton.edu/pipermail/parsec-users/attachments/20101024/9c53b137/attachment.html>


More information about the parsec-users mailing list