[parsec-users] freqmine: segmentation fault on simlarge input

Joseph Greathouse jlgreath at umich.edu
Wed May 16 21:01:34 EDT 2012


For what it's worth, this may be a problem that is system setup 
dependent. Freqmine compiles and works fine for me with simlarge on RHEL 
6.2 (x86-64), kernel version 2.6.32, GCC version 4.4.6.

I can try setting up an Ubuntu VM at some point and seeing if I can 
recreate this crash, if no one else has seen it.

It's also worth nothing that this function also contains a data race 
that has not been publicly patched yet. The uses of 
release_node_array_before_mining() and release_node_array_after_mining() 
within FP_growth_first() should actually be OMP Critical regions.

You could try adding "#pragma omp critical" before each of the calls to 
those functions. I never sat down and figured out the possible errors 
that this data race could cause (I don't think it would cause your 
crashes), but it's worth testing.

-Joe

On 5/15/2012 1:17 PM, Amittai Aviram wrote:
> I forgot to mention in the posting below that I am encountering this problem with freqmine with the OpenMP configuration.
>
> Amittai Aviram
>
> On May 15, 2012, at 3:55 AM, Amittai Aviram wrote:
>
>> Hi!  I am getting a segmentation fault when running freqmine with any number of threads (I have tried 1, 2, 4, and 8), using the "simlarge" input (kosarek_990k.dat).  The problem occurs consistently in FP_tree::FP_growth_first, in file fp_tree.cpp, line 1312:
>>
>> /* Lines 1311-1312: */
>>         for (int k = 0; k<  hot_node_num; k ++)
>>                 hashtable[0][k] = NULL;
>>
>> The segmentation fault seems to occur when k == 1, and it seems to occur in the master thread (or at least occurs in that thread first on my system).  I have tried to do more investigations and experiments, but, so far, I have not found a solution.
>>
>> Oddly, freqmine runs fine with the even larger "native" input.
>>
>> I am running PARSEC on Ubuntu-linux x86_64 (server), kernel 2.6.32, on a 12-core AMD machine.  I left the compilation defaults intact in parsegmgmt, so it's using g++, which is version 4.4.3.
>>
>> Has anybody else encountered this problem?  Thanks!
>>
>> Amittai Aviram
>> PhD Student in Computer Science
>> Yale University
>> 646 483 2639
>> amittai.aviram at yale.edu
>> http://www.amittai.com


More information about the parsec-users mailing list