[parsec-users] parsec-users Digest, Vol 52, Issue 6

Yu Zhang zhangyu2004 at hotmail.com
Wed May 30 15:52:07 EDT 2012


Hallo Akshatha,

if the PARSEC package was correctly built following the instructions of the README file as,

parsec -a build

 there should be no problem to run it like this:

parsec-2.1/bin/parsecmgmt -a run -p freqmine -i native
or simply all the applications:
parsec-2.1/bin/parsecmgmt -a run

it's also possible to run them without parsecmgmt:

parsec-2.1/pkgs/apps/blackscholes/inst/amd64-linux.gcc/bin/blackscholes 1 parsec-2.1/pkgs/apps/blackscholes/run/in_10M.txt parsec-2.1/pkgs/apps/blackscholes/run/prices.txt
parsec-2.1/pkgs/apps/bodytrack/inst/amd64-linux.gcc/bin/bodytrack parsec-2.1/pkgs/apps/bodytrack/run/sequenceB_261 4 261 4000 5 0 1
parsec-2.1/pkgs/kernels/canneal/inst/amd64-linux.gcc/bin/canneal 1 15000 2000 parsec-2.1/pkgs/kernels/canneal/run/2500000.nets 6000
parsec-2.1/pkgs/kernels/dedup/inst/amd64-linux.gcc/bin/dedup -c -p -f -t 1 -i parsec-2.1/pkgs/kernels/dedup/run/FC-6-x86_64-disc1.iso -o output.dat.ddp

cd parsec-2.1/pkgs/apps/facesim/run
../inst/amd64-linux.gcc/bin/facesim -timing -threads 1 -lastframe 100
cd

parsec-2.1/pkgs/apps/ferret/inst/amd64-linux.gcc/bin/ferret parsec-2.1/pkgs/apps/ferret/run/corel lsh parsec-2.1/pkgs/apps/ferret/run/queries 50 20 1 parsec-2.1/pkgs/apps/ferret/run/output.txt
parsec-2.1/pkgs/apps/fluidanimate/inst/amd64-linux.gcc/bin/fluidanimate 1 500 parsec-2.1/pkgs/apps/fluidanimate/run/in_500K.fluid parsec-2.1/pkgs/apps/fluidanimate/run/out.fluid
parsec-2.1/pkgs/apps/freqmine/inst/amd64-linux.gcc/bin/freqmine parsec-2.1/pkgs/apps/freqmine/run/webdocs_250k.dat 11000
parsec-2.1/pkgs/apps/raytrace/inst/amd64-linux.gcc/bin/rtview parsec-2.1/pkgs/apps/raytrace/run/thai_statue.obj -nodisplay -automove -nthreads 1 -frames 200 -res 1920 1080
parsec-2.1/pkgs/kernels/streamcluster/inst/amd64-linux.gcc/bin/streamcluster 10 20 128 1000000 200000 5000 none parsec-2.1/pkgs/kernels/streamcluster/run/output.txt 1
parsec-2.1/pkgs/apps/swaptions/inst/amd64-linux.gcc/bin/swaptions -ns 128 -sm 1000000 -nt 1 
parsec-2.1/pkgs/apps/vips/inst/amd64-linux.gcc/bin/vips im_benchmark parsec-2.1/pkgs/apps/vips/run/orion_18000x18000.v parsec-2.1/pkgs/apps/vips/run/output.v 
parsec-2.1/pkgs/apps/x264/inst/amd64-linux.gcc/bin/x264 --quiet --qp 20 --partitions b8x8,i4x4 --ref 5 --direct auto --b-pyramid --weightb --mixed-refs --no-fast-pskip --me umh --subme 7 --analyse b8x8,i4x4 --threads 1 -o parsec-2.1/pkgs/apps/x264/run/eledream.264 parsec-2.1/pkgs/apps/x264/run/eledream_1920x1080_512.y4m

to achieve this, the input and output files should be supplied without mistake, or else strange error messages arise, difficult to understand it.

Yu Zhang
Computer Architecture Group
TU Chemnitz
2012.05.30

From: parsec-users-request at lists.cs.princeton.edu
Subject: parsec-users Digest, Vol 52, Issue 6
To: parsec-users at lists.cs.princeton.edu
Date: Tue, 15 May 2012 12:00:06 -0400

Send parsec-users mailing list submissions to
	parsec-users at lists.cs.princeton.edu
 
To subscribe or unsubscribe via the World Wide Web, visit
	https://lists.cs.princeton.edu/mailman/listinfo/parsec-users
or, via email, send a message with subject or body 'help' to
	parsec-users-request at lists.cs.princeton.edu
 
You can reach the person managing the list at
	parsec-users-owner at lists.cs.princeton.edu
 
When replying, please edit your Subject line so it is more specific
than "Re: Contents of parsec-users digest..."


--Forwarded Message Attachment--
From: fdm546 at my.utsa.edu
To: parsec-users at lists.cs.princeton.edu
Date: Mon, 14 May 2012 14:52:33 -0500
Subject: [parsec-users] Freqmine does not execute from external directory

Hi PARSEC users, I am trying to run parsec/freqmine benchmark from an external directory. Even though I specify a full path for 'parsecmgmt', the benchmark does not execute. However, I am able to build/uninstall this benchmark from the external directory, execution doesn't work. 

This is the error I get:[PARSEC] Error: Binary '/home/parsec-2.1/pkgs/apps/freqmine/inst/amd64-linux.gcc-openmp/bin/freqmine' of package 'freqmine' cannot be found.

I tried setting PARSECDIR env variable to parsec folder, however the error still exists..
The benchmark executes fine when run from parsec directory.Any ideas on this?

ThanksAkshatha


--Forwarded Message Attachment--
From: amittai.aviram at yale.edu
To: parsec-users at lists.cs.princeton.edu
Date: Mon, 14 May 2012 17:57:05 -0400
Subject: [parsec-users] Small bug in env.sh

Every time I would run "source env.sh," I would get this error message:
 
dirname: invalid option -- 'b'
Try `dirname --help' for more information.
dirname: missing operand
Try `dirname --help' for more information.
 
The script would otherwise work in setting the environment variables correctly, but the error message was annoying.  I finally found out why error happens--see this page:
 
http://lists.gnu.org/archive/html/bug-coreutils/2011-04/msg00037.html
 
To correct this behavior, I had to insert "--" after each instance of "${xxDIRNAMExx}."  I would like to suggest this change for future releases of PARSEC.  Below by signature is a suggested patch (env.sh.patch).
Amittai Aviram
PhD Student in Computer Science
Yale University
646 483 2639
amittai.aviram at yale.edu
http://www.amittai.com
 
--- env.sh      2012-05-14 17:40:12.250491791 -0400
+++ env_new.sh  2012-05-14 17:31:43.697577348 -0400
@@ -37,14 +37,14 @@
     # Try to extract absoute or relative path
     if [ "${0:0:1}" == "/" ]; then
       # Absolute path given
-      eval xxparsecdirxx=$(${xxDIRNAMExx} $(${xxDIRNAMExx} $0))
+      eval xxparsecdirxx=$(${xxDIRNAMExx} -- $(${xxDIRNAMExx} -- $0))
       # Check
       if [ -f "${xxparsecdirxx}/${xxuniquefilexx}" ]; then
         xxPARSECDIRxx=${xxparsecdirxx}
       fi
     else
       # No absolute path, maybe relative path?
-      eval xxparsecdirxx=$(${xxPWDxx})/$(${xxDIRNAMExx} $(${xxDIRNAMExx} $0))
+      eval xxparsecdirxx=$(${xxPWDxx})/$(${xxDIRNAMExx} -- $(${xxDIRNAMExx} -- $0))
       # Check
       if [ -f "${xxparsecdirxx}/${xxuniquefilexx}" ]; then
         xxPARSECDIRxx=${xxparsecdirxx}
 
 


--Forwarded Message Attachment--
From: amittai.aviram at yale.edu
To: parsec-users at lists.cs.princeton.edu
Date: Tue, 15 May 2012 03:55:21 -0400
Subject: [parsec-users] freqmine: segmentation fault on simlarge input

Hi!  I am getting a segmentation fault when running freqmine with any number of threads (I have tried 1, 2, 4, and 8), using the "simlarge" input (kosarek_990k.dat).  The problem occurs consistently in FP_tree::FP_growth_first, in file fp_tree.cpp, line 1312:
 
/* Lines 1311-1312: */
        for (int k = 0; k < hot_node_num; k ++)
                hashtable[0][k] = NULL;
 
The segmentation fault seems to occur when k == 1, and it seems to occur in the master thread (or at least occurs in that thread first on my system).  I have tried to do more investigations and experiments, but, so far, I have not found a solution.
 
Oddly, freqmine runs fine with the even larger "native" input.
 
I am running PARSEC on Ubuntu-linux x86_64 (server), kernel 2.6.32, on a 12-core AMD machine.  I left the compilation defaults intact in parsegmgmt, so it's using g++, which is version 4.4.3.
 
Has anybody else encountered this problem?  Thanks!
 
Amittai Aviram
PhD Student in Computer Science
Yale University
646 483 2639
amittai.aviram at yale.edu
http://www.amittai.com
 
 
 		 	   		  
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.cs.princeton.edu/pipermail/parsec-users/attachments/20120531/e32f9c96/attachment.htm>


More information about the parsec-users mailing list