[parsec-users] Problems with PARSEC-3.0

Juan Cebrian juanmc at idi.ntnu.no
Wed Sep 19 08:20:23 EDT 2012

Hi. Indeed, installing the library libtiff4-dev should solve the problem, but I think PARSEC is meant to be lib-independent, so building from the code available in the libtiff folder should be the best option.


De: Yu Zhang [zhangyu2004 at hotmail.com]
Enviado el: miércoles, 19 de septiembre de 2012 10:20
Para: parsec
Asunto: [parsec-users] Problems with PARSEC-3.0

Hello PARSEC group,

One year ago I began to use PARSEC-2.1 benchmark suite, and feel it really an excellent tool for performance measurement. Recently I had also tried with PARSEC-3.0 but encountered the following problems:

1. The Building process terminated with an error caused by  ARCH = $(shell uname -i) in parsec-3.0/pkgs/libs/uptcpip/src/Makefile, which on my debian- should be modified to ARCH = $(shell uname -m) .

2. I feel rather confused when running the benchmark, the following information appeared:

zhayu at streich:~/parsec-3.0/bin$ parsecmgmt -a run -p all
[PARSEC] Benchmarks to run:  parsec.blackscholes parsec.bodytrack parsec.canneal parsec.cmake parsec.dedup parsec.facesim parsec.ferret parsec.fluidanimate parsec.freqmine parsec.glib parsec.gsl parsec.hooks parsec.libjpeg parsec.libtool parse! c.libxml2 parsec.mesa parsec.netdedup parsec.netferret parsec.netstreamcluster parsec.parmacs parsec.raytrace parsec.ssl parsec.streamcluster parsec.swaptions parsec.tbblib parsec.uptcpip parsec.vips parsec.x264 parsec.yasm parsec.zlib splash2.barnes splash2.cholesky splash2.fft splash2.fmm splash2.lu_cb splash2.lu_ncb splash2.ocean_cp splash2.ocean_ncp splash2.radiosity splash2.radix splash2.raytrace splash2.volrend splash2.water_nsquared splash2.water_spatial splash2x.barnes splash2x.cholesky splash2x.fft splash2x.fmm splash2x.lu_cb splash2x.lu_ncb splash2x.ocean_cp splash2x.ocean_ncp splash2x.radiosity splash2x.radix splash2x.raytrace splash2x.volrend splash2x.water_nsquared splash2x.water_spatial

[PARSEC] [========== Running benchmark parsec.blackscholes [1] ==========]
[PARSEC] Deleting old run directory.
[PARSEC] Setting up run directory.
[PARSEC] Unpacking benchmark input 'test'.
[PARSEC] Running 'time /home/zhayu/parsec-3.0/pkgs/apps/b! lackscholes/inst/amd64-linux.gcc/bin/blackscholes 1 in_4.txt prices.tx t':
[PARSEC] [---------- Beginning of output ----------]
PARSEC Benchmark Suite Version 3.0-beta-20120904
Num of Options: 4
Num of Runs: 100
Size of data: 160

real    0.003
user    0.004
sys    0.000
[PARSEC] [----------    End of output    ----------]

[PARSEC] [========== Running benchmark parsec.bodytrack [1] ==========]
[PARSEC] Deleting old run directory.
[PARSEC] Setting up run directory.
[PARSEC] Unpacking benchmark input 'test'.
sequenceB_1/CAM4/image0000.bm! p
[PARSEC] Running 'time /home/zhayu/parsec-3.0/pkgs/apps/bodytrack/inst/amd64-linux.gcc/bin/bodytrack sequenceB_1 4 1 5 1 0 1':
[PARSEC] [---------- Beginning of output ----------]
PARSEC Benchmark Suite Version 3.0-beta-20120904
Threading with Posix Threads
Number of threads : 1
Using dataset : sequenceB_1/
5 particles with 1 annealing layers

Processing frame 0

real    0.139
user    0.120
sys    0.020
[PARSEC] [----------    End of output    ----------]

[PARSEC] [========== Running benchmark parsec.canneal [1] ==========]
[PARSEC] Deleting old run directory.
[PARSEC] Set! ting up run directory.
[PARSEC] Unpacking benchmark input 'test'.10.nets
[PARSEC] Running 'time /home/zhayu/parsec-3.0/pkgs/kernels/canneal/inst/amd64-linux.gcc/bin/canneal 1 5 100 10.nets 1':
[PARSEC] [---------- Beginning of output ----------]
PARSEC Benchmark Suite Version 3.0-beta-20120904
Threadcount: 1
5 swaps per temperature step
start temperature: 100
netlist filename: 10.nets
number of temperature steps: 1
locs created
locs assigned
netlist created. 10 elements.
Final routing is: 132

real    0.004
user    0.004
sys    0.000
[PARSEC] [----------    End of output    ----------]

[PARSEC] [========== Running benchmark parsec.cmake [1] ==========]
[PARSEC] Error: Cannot find run configuration 'test.runconf' for package parsec.cmake.

I don't know whether libs and tools are also co! nsidered as benchmark applications. If yes, they should also be provided with the corresponding configuration files such as 'test.runconf' etc (or else can't be started). If on the other hand, they serve only as libraries of dependency-resolution for apps, kernels and netapps, why they also appear as the benchmark started?

3. Finally I think the problem below could be solved by installing the package : libtiff4-dev


[PARSEC] [========== Building package splash2.volrend [2] ==========]
[PARSEC] [---------- Analyzing package splash2.volrend ----------]
[PARSEC] splash2.volrend depends on: hooks
[PARSEC] [---------- Analyzing package parsec.hooks ----------]
[PARSEC] Package parsec.hooks already exists, proceeding.
[PARSEC] [---------- Building package splash2.volrend ----------]
[PARSEC] Removing old build directory.
[PARSEC] Copying source code of package splash2.volrend.
[PARSEC] Running 'env version=IN_PARSEC /usr/bin/make':
m4 ../../../../null_macros/c.m4.null.pthread user_options.H > user_options.h
gcc -c -O2 -w -DPRESHD -Ilibtiff raytrace.c
gcc main.o file.o option.o map.o normal.o opacity.o octree.o view.o render.o adaptive.o raytrace.o -O2 -w -DPRESHD -Ilibtiff -o volrend -O2 -w -pthread -lm -Ilibtiff -Llibtiff -ltiff
/usr/bin/ld: cannot find -ltiff
collect2: ld returned 1 exit status
make: *** [volrend] Error 1
[PARSEC] Error: 'env version=IN_PARSEC /usr/bin/make' failed.

SOLUTION: (MANUAL SOLUTION, You should find out what is the best solution to fix this, either moving libtiff to /pkgs/libs and changing gcc.bldconf or rebuilding makefile structures)

edit: ext/splash2/apps/volrend/src/libtiff/Makefile and define BSDTYPES, for example:


then build with make in ext/splash2/apps/volrend/src/libtiff


Yu Zhang
Professur Rechnerarchtektur
TU Chemnitz

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.cs.princeton.edu/pipermail/parsec-users/attachments/20120919/020768ec/attachment.htm>

More information about the parsec-users mailing list