[parsec-users] Netapps on ARMV7l - Odroid XU4

Marcelo Novaes novaes.ssa at gmail.com
Mon Apr 10 05:54:18 EDT 2017


Hello guys, I'm sorry for the noob question

I'm trying to compile the netapps at my Odroid XU4(ARM - Ubuntu 16.04). When
I try, I get the following message:

/include/sys/bsd_types.h:44:32: fatal error: machine/bsd_endian.h:

So, I went to the parsec-3.0/pkgs/libs/uptcpip/src and tried to do a make.
I got:

> cp: cannot stat 'armv7l':

It happens because of the line: ARCH = $(shell uname -m). It will set
armv7l to ARCH. Then, will look for network related files at armv7l folder.
However, this is not the path where my endian.h, types.h, etc (network
necessary header files)... are. In order to fix that, I saw where my
network related .h files were /usr/include/arm-linux-gnueabihf/ and
/usr/include/ and put them inside the
/parsec-3.0/pkgs/libs/uptcpip/src/include. Then, I used a script to change
the name of all network realted files to add the bsd_ as prefix (e.g.
bsd_endian.h). However, I am still lacking a final step. The apps cannot
find yet the bsd_endian.h for example. I still get the same error.

Is there someone that could give me a hint?

*PS: firstly I’m so sorry if you have received this message more than once.
It appeared for me that the message wasn’t been sent.*

Best, Marcelo
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.cs.princeton.edu/pipermail/parsec-users/attachments/20170410/290453f1/attachment.html>


More information about the parsec-users mailing list