[sndtools] sndpeek build fails on linux

Tristan Matthews le.businessman at gmail.com
Wed Mar 4 13:59:48 EST 2015


On Wed, Mar 4, 2015 at 1:47 PM, Orm Finnendahl
<orm.finnendahl at selma.hfmdk-frankfurt.de> wrote:
> Am Mittwoch, den 04. März 2015 um 13:35:00 Uhr (-0500) schrieb Tristan Matthews:
>> This patch fixes it here.
>
> thanks, I fixed it similarly and it compiles now. Unfortunately starting it yields this:
>
> .../sndpeek-1.4/src/sndpeek$ sndpeek
>
> RtApiDummy: This class provides no functionality.
>
> [sndpeek]: ERROR: no audio devices found!
> .../sndpeek-1.4/src/sndpeek$
>
>
> The binary was compiled with 'make linux-jack'. Jack is up and
> running before starting sndpeek.

Ah, you need to add -D__UNIX_JACK__ (in addition to the already
present -D__LINUX_JACK__) to CFLAGS in makefile.jack, this is because
Stk and RtAudio use different defines for Jack support.

>
> I also tried to compile with 'make linux-alsa', but that fails
> here:
>
> g++ -o sndpeek chuck_fft.o RtAudio.o Thread.o sndpeek.o Stk.o Centroid.o DownSampler.o Flux.o LPC.o MFCC.o RMS.o Rolloff.o System.o fvec.o AutoCorrelation.o Communicator.o Hamming.o MagFFT.o NormRMS.o MarSignal.o fmatrix.o -L/usr/X11R6/lib -lglut -lGL -lGLU -lasound -lXmu -lX11 -lXext -lXi -lm -lsndfile
> /usr/bin/ld: Thread.o: undefined reference to symbol 'pthread_cancel@@GLIBC_2.2.5'
> //lib/x86_64-linux-gnu/libpthread.so.0: error adding symbols: DSO missing from command line
> collect2: error: ld returned 1 exit status
> makefile.alsa:15: recipe for target 'sndpeek' failed
> make[1]: *** [sndpeek] Error 1
> make[1]: Leaving directory '.../sndpeek-1.4/src/sndpeek'
> makefile:20: recipe for target 'linux-alsa' failed
> make: [linux-alsa] Error 2 (ignored)
> .../sndpeek-1.4/src/sndpeek$

Add -pthread to LIBS in makefile.alsa

>
> --
> Orm
> _______________________________________________
> sndtools mailing list
> sndtools at lists.cs.princeton.edu
> https://lists.cs.princeton.edu/mailman/listinfo/sndtools


More information about the sndtools mailing list