[Topic-models] ctm-c compile error in makefile

Sauparna Palchowdhury sauparna.palc at gmail.com
Wed Mar 29 16:44:25 EDT 2017


The ATLAS library (http://math-atlas.sourceforge.net) is not installed
on your machine. Try this:

Get the software from here, there is a link to the zip file:
https://sourceforge.net/projects/math-atlas/files/Stable/

Then, follow the steps mentioned at the bottom of this page starting
with 'bunzip2 -c ...':
http://math-atlas.sourceforge.net/atlas_install/node6.html

I use a Mac where compilation fails because of a missing 'glsl'
library but not for a missing 'latlas'. I haven't put in the time to
work around that, but my (theoretical) understanding is installing the
ATLAS library could solve your issue.

If you are stuck please post the error logs again, I'll take a look.

-
rup

On Wed, Mar 29, 2017 at 3:14 AM, Weining Hu <weininghu1012 at gmail.com> wrote:
> Hi,
> When I try to run the compile step
> https://github.com/Blei-Lab/ctm-c/blob/master/README
> I came into this error:
>
> make
>
> gcc inference.o gsl-wrappers.o ctm.o estimate.o corpus.o params.o -o ctm -lm
> -lgsl -latlas -lgslcblas
>
> ld: library not found for -latlas
>
> clang: error: linker command failed with exit code 1 (use -v to see
> invocation)
>
> make: *** [mac] Error 1
>
>
> Could you have a look into it? Thanks!
>
>
> --
> Best,
> Weining
>
> _______________________________________________
> Topic-models mailing list
> Topic-models at lists.cs.princeton.edu
> https://lists.cs.princeton.edu/mailman/listinfo/topic-models
>


More information about the Topic-models mailing list