[chuck-users] machine add oddity

Kassen signal.automatique at gmail.com
Tue Feb 14 19:01:46 EST 2012

On Tue, Feb 14, 2012 at 05:36:07PM -0600, Jeff Albert wrote:
> Good point. Chuck says the shred is sparked, we just get no sound. 

Up to here it sounds fairly normal....

>     Have you tried stuff like editing the offending file to start with a
>     debug print?
> If I run either file alone, they each work, individually. 

Right, so here it gets truly interesting. So these somehow affect each
other, perhaps using some common resource? Perhaps something like a
system path is set? Is any sort of global name-space involved?

It'd also be interesting to see whether they *finish* running without
sound or whether they get stuck at some time before that?

> This sounds like a good lead. I think he wrote the files in miniaudicle on
> Windows (although he is running them from the command line), but he may have
> copied/pasted some of it from some Mac generated files I gave him. I'll follow
> that up.

If they each run individually on both systems I suspect it's not this
(but weirder things have happened). I suspect some sort of common
resource is affected in some sort of unforeseen way. Probably some
sort of bug in one of the places where the VM touches on the host OS.

If the files are of a reasonable size you could try either stripping
them of suspicious bits until they work or start with nothing and add
parts of the file until it breaks.

If there is time and space for that you could suggest that your
student do that and that (s)he send a bug report, IMHO that's a skill
that also deserves some time in a learning environment.

Good luck,

More information about the chuck-users mailing list