[chuck-users] [solved] Re: OscIn: error: unable to create server instance

ermina at studioplume.com ermina at studioplume.com
Tue Jun 9 17:09:49 EDT 2015


well, netstat did not give any indication of problems with ports, so i 
investigated a little more and found that it has to do with the jackd 
server. I use the realtime scheduling option in jackd.
If i start jackd with the -m (no memory lock) option, the problem i was 
describing earlier does not occur.
So, issue solved/workarounded.
Back to the book :)

. e

On 2015-06-09 21:37, Spencer Salazar wrote:
> Hi,
> Interesting, someone has actually reported this in the past but Ive
> never been able to reproduce it. The two most likely explanations are
> either opening up a UDP listener port is forbidden by some
> security/firewall policy on your system (many OS's have started
> enabling these by default), or something else is using the port you
> are trying to create the OSC server on. 
> Im not sure how to test the former on Linux, but you can see if
> anything is listening on that port using netstat -lntu. If any of the
> ports on the local addresses (the part after : ) matches the OSC port
> you are trying to use, then that would be your problem- you can just
> use a different OSC port in ChucK in that case. 
> spencer

More information about the chuck-users mailing list