[chuck-users] chugins will not load/compile using on windows10

Ben Sandvik bpsandvik at gmail.com
Wed May 16 02:10:03 EDT 2018

I have been trying to update to chuck for a few days, but I can't
get chugins to compile or load on Windows 10 64-bit using miniAudicle.  I'm
getting the "undefined type '...'  in declaration" error message for every
chugin when adding to the VM, including ones that had been working
correctly with  Other .ck files that don't use chugins seem to be
working fine.  Here is what I have tried

Downloaded the 1.4 executable and went through the standard installation

I have copied the files from the chugins GitHub zip file to:

and made sure the directory is listed under the chugins preferences in
miniAudicle.  Not sure which is best directory, just trying everything.
I have also tried just putting the github files for a specific chugin in
the same folder with an example .ck files.  Still the same error message.
If I uninstall 1.4 and re-install the older chugins are working
fine, but newer ones like Wavetable and ExpEnv are not.

Any ideas?  Am I missing some obvious step during installation?  Is there a
Windows10-specific issue?
Also, not sure if this is related, but changing the Log Level to anything
other than System causes miniAudicle to crash when starting the vm.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.cs.princeton.edu/pipermail/chuck-users/attachments/20180516/58047ac2/attachment.html>

More information about the chuck-users mailing list