[chuck-users] chugins will not load/compile using on windows10

Jack Atherton lja at ccrma.stanford.edu
Wed May 16 02:19:28 EDT 2018

I am pretty sure that chugins that worked with 1.3.X have an internal
version number that is incompatible with -- the API for chugins
changed. You could try recompiling the chugins from the chugin repo and
seeing if that works. I am not sure if the Windows installer also installs
chugins like the Mac installer does (at least, I'm pretty sure the Mac
installer does).

That sounds nasty about the log level crash. I wonder if it is something
that happens when attempting to load incompatible chugins... we should
probably fix it if that's what's going on!


On Tue, May 15, 2018 at 11:10 PM, Ben Sandvik <bpsandvik at gmail.com> wrote:

> List,
> I have been trying to update to chuck for a few days, but I can't
> get chugins to compile or load on Windows 10 64-bit using miniAudicle.  I'm
> getting the "undefined type '...'  in declaration" error message for every
> chugin when adding to the VM, including ones that had been working
> correctly with  Other .ck files that don't use chugins seem to be
> working fine.  Here is what I have tried
> Downloaded the 1.4 executable and went through the standard installation
> I have copied the files from the chugins GitHub zip file to:
> C:\WINDOWS\system32/ChucK
> C:\ProgramFiles\ChucK\chugins
> C:\ProgramFiles(x86)\ChucK\chugins
> and made sure the directory is listed under the chugins preferences in
> miniAudicle.  Not sure which is best directory, just trying everything.
> I have also tried just putting the github files for a specific chugin in
> the same folder with an example .ck files.  Still the same error message.
> If I uninstall 1.4 and re-install the older chugins are working
> fine, but newer ones like Wavetable and ExpEnv are not.
> Any ideas?  Am I missing some obvious step during installation?  Is there
> a Windows10-specific issue?
> Also, not sure if this is related, but changing the Log Level to anything
> other than System causes miniAudicle to crash when starting the vm.
> thanks
> Ben
> <https://www.avast.com/sig-email?utm_medium=email&utm_source=link&utm_campaign=sig-email&utm_content=webmail&utm_term=icon> Virus-free.
> www.avast.com
> <https://www.avast.com/sig-email?utm_medium=email&utm_source=link&utm_campaign=sig-email&utm_content=webmail&utm_term=link>
> <#m_7236496386533434902_DAB4FAD8-2DD7-40BB-A1B8-4E2AA1F9FDF2>
> _______________________________________________
> chuck-users mailing list
> chuck-users at lists.cs.princeton.edu
> https://lists.cs.princeton.edu/mailman/listinfo/chuck-users
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.cs.princeton.edu/pipermail/chuck-users/attachments/20180515/726c28eb/attachment.html>

More information about the chuck-users mailing list