[chuck-users] Mic on Mini on Mojave+

Perry Cook prc at cs.princeton.edu
Mon Mar 1 22:01:58 EST 2021

Hi all,

Since Mojave, MacOS has instituted increasing security restrictions on Mic (and Camera) use.
One of my Mojave machines at least launched the “MiniAudicle wants access to your microphone” dialog, and Mini now shows up in the Security pane of System Preferences.

BUT, opening adc with system Mic selected just ylelds zeroes.  Running the very same ChucK code:

adc => Gain g => blackhole; // or dac
while (1)  {
    <<< now/second, g.last() >>>;
   second/10 => now;

in Terminal yields the usual non-zero mic output floats on the adc channel.

Running it in Mini yields zeroes.  I’ve tried it with multiple mic devices (headphone External Mic) and same result, zeroes on Mini.

I actually used LoopBack to stream the mic into a virtual dac in Terminal, then selected that Loopback channel as my input in MiniAudicle.  That solution works, but costs $$, and of course ChucK MiniAudicle should be able to see and use the mic.

Anyone run into this and have a solution?   


While we’re at it, has anyone dealt with this yet for Processing (mic and camera don’t work, no dialog box from system)???

More information about the chuck-users mailing list