[chuck-users] [chuck users] Mic on Mini on Mojave+

David Loberg Code d.loberg.code at wmich.edu
Tue Mar 2 12:50:25 EST 2021

I have students who have encountered this general problem with mics, keyboard, and trackpads (with OSX 10.14/15 and OSX 11)
Personally, I have never gotten miniAud to trigger the "wants to access" prompt yet.
I use this work-around:  Open the application Terminal and type the following:

open /Applications/miniAudicle.app/Contents/MacOS/miniAudicle

This opens miniAudicle via Terminal which allows it to inherit all of the access permissions of Terminal.  The above link is assuming that your miniAudicle is located in the Applications folder on your drive. Otherwise you will need a different directory path.



David Loberg Code

School of Music

Western Michigan

code at wmich.edu

any pronouns

[chuck-users] Mic on Mini on Mojave+
Perry Cook <prc at cs.princeton.edu>

 chuck-users at lists.cs.princeton.edu

Hi all,

Since Mojave, MacOS has instituted increasing security restrictions on Mic (and Camera) use.
One of my Mojave machines at least launched the “MiniAudicle wants access to your microphone” dialog, and Mini now shows up in the Security pane of System Preferences.

BUT, opening adc with system Mic selected just ylelds zeroes.  Running the very same ChucK code:

adc => Gain g => blackhole; // or dac
while (1)  {
    <<< now/second, g.last() >>>;
   second/10 => now;

in Terminal yields the usual non-zero mic output floats on the adc channel.

Running it in Mini yields zeroes.  I’ve tried it with multiple mic devices (headphone External Mic) and same result, zeroes on Mini.

I actually used LoopBack to stream the mic into a virtual dac in Terminal, then selected that Loopback channel as my input in MiniAudicle.  That solution works, but costs $$, and of course ChucK MiniAudicle should be able to see and use the mic.

Anyone run into this and have a solution?


While we’re at it, has anyone dealt with this yet for Processing (mic and camera don’t work, no dialog box from system)???

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.cs.princeton.edu/pipermail/chuck-users/attachments/20210302/a803cfdc/attachment.html>

More information about the chuck-users mailing list