[chuck-users] Installing on 64bit Ubuntu?

Martin Ahnelöv operagasten at gmail.com
Wed Oct 31 06:24:28 EDT 2007

ons 2007-10-31 klockan 02:39 -0700 skrev Eric Hedekar:
> Hi, I recently tried to get chuck working on my new UbuntuStudio 64bit
> install and I can't get it to work properly.  
> When I "make linux-jack" it seems to go okay and the last couple lines
> are as follows: 
> g++ -D__LINUX_JACK__ -c -O3 -D__CK_SNDFILE_NATIVE__ uana_xform.cpp
> g++ -D__LINUX_JACK__ -c -O3 -D__CK_SNDFILE_NATIVE__ uana_extract.cpp
> g++ -o chuck chuck.tab.o chuck.yy.o chuck_absyn.o chuck_parse.o
> chuck_errmsg.o chuck_frame.o chuck_symbol.o chuck_table.o
> chuck_utils.o chuck_vm.o chuck_instr.o chuck_scan.o chuck_type.o
> chuck_emit.o chuck_compile.o chuck_dl.o chuck_oo.o chuck_lang.o
> chuck_ugen.o chuck_main.o chuck_otf.o chuck_stats.o chuck_bbq.o
> chuck_shell.o chuck_console.o chuck_globals.o digiio_rtaudio.o
> hidio_sdl.o midiio_rtmidi.o rtaudio.o rtmidi.o ugen_osc.o
> ugen_filter.o ugen_stk.o ugen_xxx.o ulib_machine.o ulib_math.o
> ulib_std.o ulib_opsc.o util_buffers.o util_console.o util_string.o
> util_thread.o util_opsc.o util_math.o util_network.o util_raw.o
> util_xforms.o util_hid.o uana_xform.o uana_extract.o  -lasound -ljack
> -lstdc++ -ldl -lm -lsndfile 
> make[1]: Leaving directory
> then when I run "chuck moe.ck" I get:
> JACK tmpdir identified as [/dev/shm]
> Enhanced3DNow! detected
> SSE2 detected
> JACK tmpdir identified as [/dev/shm] 
> Enhanced3DNow! detected
> SSE2 detected
> JACK tmpdir identified as [/dev/shm]
> Enhanced3DNow! detected
> SSE2 detected
> Segmentation fault (core dumped)
> Where is my problem lying?  I'm of the linux age where I shouldn't
> have to understand how to compile from code to get things to run and
> the Chuck install instructions say nothing about which programs and
> libraries (other than libsndfile) are required etc.. to make.  That
> info would be a very good addition on the next release. 

Oh, well, this is experimental software. But you're right. I am thinking
of getting off my butt and learn how to compile chuck-deb.

Are you sure you got jack installed (sudo aptitude install jackd
qjackctl)? is it running? Can you get any sound out of it? 

Have you tried to make linux-alsa? does it work?

A far as I'm aware, there shouldn't be any 64-bitness in Jack. What
version are you using?

Also, try chuck --probe.

Hope that helps,

More information about the chuck-users mailing list