[chuck-users] sndfilelib for compiling chuck 1.3...

Forrest Curo treegestalt at gmail.com
Wed Sep 23 16:48:25 EDT 2015

I've just tried the instructions for compiling/installing chuck 1.3; and
these worked exactly as given, on a confuser running ubuntu 15.04.

On another, with ubuntu 14.04 -- I find the compilation crashing for lack
of "asoundlib.h"

Assuming that this is part of the libsndfile listed as a dependency on your
download page, I followed the link to
http://www.mega-nerd.com/libsndfile/#Download and installed that.

However, back in the .... chuck/src directory, I'm still getting:
~/chuck-$ make linux-alsa
g++ -I. -Ilo -O3 -D__LINUX_ALSA__ -D__PLATFORM_LINUX__ -O3
-fno-strict-aliasing -D__CK_SNDFILE_NATIVE__  -c RtAudio/RtAudio.cpp -o
RtAudio/RtAudio.cpp:5267:28: fatal error: alsa/asoundlib.h: No such file or
 #include <alsa/asoundlib.h>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.cs.princeton.edu/pipermail/chuck-users/attachments/20150923/fa149deb/attachment.html>

More information about the chuck-users mailing list